• Bridging signals_最大上升子序列


    Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 1826    Accepted Submission(s): 1211


    Problem Description
    'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too
    expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without rossing each other, is imminent. Bearing in mind that there may be housands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task?

    Figure 1. To the left: The two blocks' ports and their signal mapping (4,2,6,3,1,5). To the right: At most three signals may be routed on the silicon surface without crossing each other. The dashed signals must be bridged. 

    A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the i:th number pecifies which port on the right side should be connected to the i:th port on the left side.
    Two signals cross if and only if the straight lines connecting the two ports of each pair do.
     
    Input
    On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p<40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping: On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side.
     
    Output
    For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.
     
    Sample Input
    4 6 4 2 6 3 1 5 10 2 3 4 5 6 7 8 9 10 1 8 8 7 6 5 4 3 2 1 9 5 8 9 2 3 1 7 4 6
     
    Sample Output
    3 9 1 4
     
    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    using namespace std;
    const int N=500005;
    int mp[N];
    int f[N];
    int findx(int x,int left,int right)
    {
        int mid;
        while(left<=right)
        {
            mid=(left+right)/2;
            if(x>=f[mid]) left=mid+1;
            else right=mid-1;
        }
        return left;
    
    }
    int solve(int n)
    {
        f[1]=mp[1];
        int len=1;
        for(int i=2; i<=n; i++)
        {
            if(mp[i]>f[len])
            {
                len=len+1;
                f[len]=mp[i];
            }
            else
            {
                int pos=findx(mp[i],1,len);
                f[pos]=mp[i];
            }
        }
        return len;
    }
    int main()
    {
        int n,t;
        int cas=0;
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d",&n);
            for(int i=1;i<=n;i++)
                cin>>mp[i];
            int ans=solve(n);
            cout<<ans<<endl;
        }
        return 0;
    }
    

      

  • 相关阅读:
    eclipse快捷键
    eclipse跑jfinal项目遇到的种种坑,java.lang.NoSuchMethodError
    ./configure ,make ,make install命令
    解决docker,ubuntu镜像中没有vi/vim
    使用qr生成二维码
    shell重定向
    ubuntu16.04启动rabbitmq报错
    HandlerMapping
    springMVC中绑定参数的常用注解
    mybatis的缓存机制
  • 原文地址:https://www.cnblogs.com/iwantstrong/p/5744168.html
Copyright © 2020-2023  润新知