• 挑战程序设计竞赛 习题 poj 3050 Hopscotch


    地址 https://vjudge.net/problem/POJ-3050

    The cows play the child's game of hopscotch in a non-traditional way. 
    Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.
    They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid.
    They hop again (same rules) to a digit (potentially a digit already visited). With a total of five intra
    -grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). Determine the count of the number of distinct integers that can be created in this manner. Input * Lines 1..5: The grid, five integers per line Output * Line 1: The number of distinct integers that can be constructed Sample Input 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 2 1 1 1 1 1 1 Sample Output 15 Hint OUTPUT DETAILS: 111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111,
    and 212121 can be constructed.
    No other values are possible.

    代码 

    #include <iostream>
    #include <set>
    #include <vector>
    
    using namespace std;
    
    int arr[6][6];
    set<vector<int>> ss;
    
    int addx[4] = {1,-1,0,0};
    int addy[4] = {0,0,-1,1};
    
    void dfs(int x,int y,vector<int>& v)
    {
      if(v.size() == 6){
        ss.insert(v); return;
      }
       v.push_back(arr[x][y]);
        for(int i =0;i < 4;i++){
          int newx = x+ addx[i];
          int newy = y +addy[i];
            if(newx>=0 && newx<5 && newy>=0 && newy <5){
                 dfs(newx,newy,v);
              }
    
        }      
     
       
      v.pop_back();
       return ;
    }
    
    int main(){
    for(int i =0; i < 5;i++){
    for(int j = 0; j<5;j++){
     cin >> arr[i][j];
    }
    }
    
    for(int i =0; i < 5;i++){
    for(int j = 0; j<5;j++){
       vector<int> v;
       dfs(i,j,v);
    }
    }
    cout << ss.size() << endl;
     return 0;
    }
  • 相关阅读:
    centos 7 pip install MySQL-python 报错
    修改centos history记录数上限
    CentOS 7 如何设置为eth0网卡
    字符串判空有空格报错:binary operator expected
    Linux指定用户运行程序
    MySQL 新建用户,为用户授权,指定用户访问数据库
    解决linux 中文乱码
    UNIX目录访问操作
    通过lseek产生空洞文件
    lseek系统调用
  • 原文地址:https://www.cnblogs.com/itdef/p/14288654.html
Copyright © 2020-2023  润新知