• 挑战程序设计竞赛 习题 poj 3050 Hopscotch


    地址 https://vjudge.net/problem/POJ-3050

    The cows play the child's game of hopscotch in a non-traditional way. 
    Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.
    They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid.
    They hop again (same rules) to a digit (potentially a digit already visited). With a total of five intra
    -grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). Determine the count of the number of distinct integers that can be created in this manner. Input * Lines 1..5: The grid, five integers per line Output * Line 1: The number of distinct integers that can be constructed Sample Input 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 2 1 1 1 1 1 1 Sample Output 15 Hint OUTPUT DETAILS: 111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111,
    and 212121 can be constructed.
    No other values are possible.

    代码 

    #include <iostream>
    #include <set>
    #include <vector>
    
    using namespace std;
    
    int arr[6][6];
    set<vector<int>> ss;
    
    int addx[4] = {1,-1,0,0};
    int addy[4] = {0,0,-1,1};
    
    void dfs(int x,int y,vector<int>& v)
    {
      if(v.size() == 6){
        ss.insert(v); return;
      }
       v.push_back(arr[x][y]);
        for(int i =0;i < 4;i++){
          int newx = x+ addx[i];
          int newy = y +addy[i];
            if(newx>=0 && newx<5 && newy>=0 && newy <5){
                 dfs(newx,newy,v);
              }
    
        }      
     
       
      v.pop_back();
       return ;
    }
    
    int main(){
    for(int i =0; i < 5;i++){
    for(int j = 0; j<5;j++){
     cin >> arr[i][j];
    }
    }
    
    for(int i =0; i < 5;i++){
    for(int j = 0; j<5;j++){
       vector<int> v;
       dfs(i,j,v);
    }
    }
    cout << ss.size() << endl;
     return 0;
    }
  • 相关阅读:
    Lc617_合并二叉树
    Lc257_二叉树的所有路径
    Lc222_完全二叉树的节点个数
    记github下载上传遇到的各种问题
    Lc101_对称二叉树
    Lc222_翻转二叉树
    二叉树的dfs 与 bfs (递归遍历)
    全球最火的程序员学习路线!没有之一!3天就在Github收获了接近1w点赞
    大二逃课总结的1.2w字的计算机网络知识!扫盲!
    「IDEA插件精选」安利一个IDEA骚操作:一键生成方法的序列图
  • 原文地址:https://www.cnblogs.com/itdef/p/14288654.html
Copyright © 2020-2023  润新知