• HDU 1671 Phone List(POJ 3630)


    Phone List

    Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 18202    Accepted Submission(s): 6115


    Problem Description
    Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
    1. Emergency 911
    2. Alice 97 625 999
    3. Bob 91 12 54 26
    In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
     
    Input
    The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
     
    Output
    For each test case, output “YES” if the list is consistent, or “NO” otherwise.
     
    Sample Input
    2
    3
    911
    97625999
    91125426
    5
    113
    12340
    123440
    12345
    98346
     
    Sample Output
    NO
    YES
     
    Source
     
     
     
    解析:字典树。
     
     
     
    #include <iostream>
    #include <cstring>
    #include <string>
    #include <algorithm>
    using namespace std;
    
    struct Node{
        Node* pt[10];
        bool isEnd;
    };
    Node* root;
    
    int n;
    string s[10005];
    Node memory[100000];
    int allo;
    
    void trie_init()
    {
        memset(memory, 0, sizeof(memory));
        allo = 0;
        root = &memory[allo++];
    }
    
    bool trie_insert(string& str)
    {
        Node *p = root, *q;
        for(int i = 0; str[i] != ''; ++i){
            int id = str[i]-'0';
            if(p->pt[id] == NULL){
                q = &memory[allo++];
                p->pt[id] = q;
            }
            else{
                if(p->pt[id]->isEnd)
                    return false;
            }
            p = p->pt[id];
        }
        p->isEnd = true;
        return true;
    }
    
    void solve()
    {
        trie_init();
        bool ok = true;
        for(int i = 0; i < n; ++i){
            ok = trie_insert(s[i]);
            if(!ok){
                cout<<"NO"<<endl;
                return;
            }
        }
        cout<<"YES"<<endl;
    }
    
    bool cmp(const string& a, const string& b)
    {
        return a.length() < b.length();
    }
    
    int main()
    {
        int t;
        cin>>t;
        while(t--){
            cin>>n;
            for(int i = 0; i < n; ++i)
                cin>>s[i];
            sort(s, s+n, cmp);
            solve();
        }
        return 0;
    }
    

      

  • 相关阅读:
    伯努利数学习笔记
    贝尔数学习笔记
    LuoguP5075 [JSOI2012]分零食
    LuoguP5748 集合划分计数
    LuoguP3338 [ZJOI2014]力
    LuoguP5488 差分与前缀和
    BZOJ4833 [Lydsy1704月赛]最小公倍佩尔数
    FFT&NTT学习笔记
    csp2019游记
    与图论的邂逅09:树上启发式合并
  • 原文地址:https://www.cnblogs.com/inmoonlight/p/5906704.html
Copyright © 2020-2023  润新知