• UVa 10815 Andy's First Dictionary


    Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

    You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.

    Input

    The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

    Output

    Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

    Sample Input

    Adventures in Disneyland

    Two blondes were going to Disneyland when they came to a fork in the
    road. The sign read: "Disneyland Left."

    So they went home.

    Sample Output

    a
    adventures
    blondes
    came
    disneyland
    fork
    going
    home
    in
    left
    read
    road
    sign
    so
    the
    they
    to
    two
    went
    were
    when

    解析:组合单词后排序去重即可。

    #include <string>
    #include <vector>
    #include <cstdio>
    #include <cctype>
    #include <cstdlib>
    #include <algorithm>
    #include <iostream>
    using namespace std;
    
    vector<string> v(100010, "");
    char ch;
    
    int main()
    {
        bool f = false;
        int i = 0;
        while(~scanf("%c", &ch)){
            if(f){
                if(isalpha(ch))
                    v[i] += tolower(ch);
                else{
                    ++i;
                    f = false;
                }
            }
            else{
                if(isalpha(ch)){
                    f = true;
                    v[i] += tolower(ch);
                }
            }
        }
        sort(v.begin(), v.begin()+i);
        int e = unique(v.begin(), v.begin()+i)-v.begin();
        for(int j = 0; j < e; ++j){
            cout<<v[j]<<endl;
        }
        return 0;
    }
    

      

  • 相关阅读:
    修改 MyEclipse 中的 jsp 和 servlet 模板
    javaWeb 数据库连接池连接数据库
    发现一个类的方法不够用时,可以使用的3种方法可以增强
    使用 greenDao 框架 操作数据库
    Android之使用Volley框架在ListView中加载大量图片
    js日期选择控件
    mysql 乱码问题
    java 使用反射技术解耦
    javaWeb 使用jsp开发 html过滤标签
    javaWeb 使用jsp开发 foreach 标签
  • 原文地址:https://www.cnblogs.com/inmoonlight/p/5701493.html
Copyright © 2020-2023  润新知