• YTU 2639: 改错题:类中私有成员的访问


    2639: 改错题:类中私有成员的访问

    时间限制: 1 Sec  内存限制: 128 MB
    提交: 431  解决: 297

    题目描述

    /*
    改错题:
    设计一个日期类和时间类,并编写全局函数display用于显示日期和时间。要求:display函数作为类外的普通函数,而不是成员函数
    在主函数中调用display函数,display函数分别引用Time和Date两个类的对象的私有数据,输出年、月、日和时、分、秒。
    下面的程序中,在begin到end部分存在语法错误。请改正错误,使程序按下面输入输出的规定运行。
    注意:只提交修改过的begin到end部分的代码。
    */
    #include <iostream>
    using namespace std;
    //将程序需要的其他成份写在下面,只提交修改后的begin到end部分的代码
    //******************** begin ********************
    class Time;  //类的提前声明
    class Date   //日期类
    {
    public:  
    Date(int y,int m,int d)
           {
                   year=y;
    month=m;
    day=d;
           }
     private:
    int year;
    int month;
    int day;
    }; 
    class Time  //时间类
    {  
    public:  
       Time(int h,int m,int s)
       {
            hour=h;
    min=m;
    sec=s;
       }
     private:
    int hour;
    int min;
    int sec;
    }; 
    void display(const Date & d, const Time & t)
    {
        cout<<d.year<<"/"<<d.month<<"/"<<d.day<<endl;
    cout<<t.hour<<":"<<t.min<<":"<<t.sec<<endl;   
    }
    //********************* end ********************
    int main()
    {
        void display(const Date &,const Time &);
        int year,month,day;
        cin>>year>>month>>day;
        Date d1(year,month,day);
        int hour,minute,second;
        cin>>hour>>minute>>second;
        Time t1(hour,minute,second);
        display(d1,t1);
        return 0;
    }

    输入

    年      月       日

    时      分       秒

    输出

    年/月/日

    时:分:秒

    样例输入

    2013  12   23
    14   23   50

    样例输出

    2013/12/23
    14:23:50

    提示

    只提交修改过的begin到end部分的代码


    迷失在幽谷中的鸟儿,独自飞翔在这偌大的天地间,却不知自己该飞往何方……

    #include <iostream>
    using namespace std;
    class Time;  //类的提前声明
    class Date   //日期类
    {
    public:
        Date(int y,int m,int d)
        {
            year=y;
            month=m;
            day=d;
        }
        int year;
        int month;
        int day;
    };
    class Time  //时间类
    {
    public:
        Time(int h,int m,int s)
        {
            hour=h;
            min=m;
            sec=s;
        }
        int hour;
        int min;
        int sec;
    };
    void display(const Date & d, const Time & t)
    {
        cout<<d.year<<"/"<<d.month<<"/"<<d.day<<endl;
        cout<<t.hour<<":"<<t.min<<":"<<t.sec<<endl;
    }
    int main()
    {
        void display(const Date &,const Time &);
        int year,month,day;
        cin>>year>>month>>day;
        Date d1(year,month,day);
        int hour,minute,second;
        cin>>hour>>minute>>second;
        Time t1(hour,minute,second);
        display(d1,t1);
        return 0;
    }
    

  • 相关阅读:
    10.28
    10.29
    11.05周四
    数据库增删改查
    11.03Tuesday
    11.10
    连接数据库
    10.30
    11.04周三
    10.27
  • 原文地址:https://www.cnblogs.com/im0qianqian/p/5989507.html
Copyright © 2020-2023  润新知