• HDU 1160:FatMouse's Speed


    FatMouse's Speed

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 13100    Accepted Submission(s): 5763
    Special Judge


    Problem Description
    FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
     

    Input
    Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

    The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

    Two mice may have the same weight, the same speed, or even the same weight and speed. 
     

    Output
    Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

    W[m[1]] < W[m[2]] < ... < W[m[n]]

    and 

    S[m[1]] > S[m[2]] > ... > S[m[n]]

    In order for the answer to be correct, n should be as large as possible.
    All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
     

    Sample Input
    6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
     

    Sample Output
    4 4 5 9 7
     

    Source
     

    Recommend
    Ignatius   |   We have carefully selected several similar problems for you:  1024 1074 1114 1025 1081 
     

    迷失在幽谷中的鸟儿,独自飞翔在这偌大的天地间,却不知自己该飞往何方……

    #include <iostream>
    #include <cstring>
    #include <algorithm>
    using namespace std;
    struct node
    {
        int w;
        int s;
        int num;
    } data[1010];
    int pre[1010];
    int len[1010];
    bool cmp(const node& A, const node& B)
    {
        if(A.w != B.w) return A.w < B.w;
        return A.s > B.s;
    }
    void print(int index)
    {
        if(len[index] == 1)
        {
            cout << data[index].num << endl;
            return;
        }
        print(pre[index]);
        cout << data[index].num << endl;
    }
    int main()
    {
        int n = 0;
        while(cin >> data[n].w >> data[n].s)
        {
            data[n].num = n + 1;
            n++;
        }
        sort(data, data + n, cmp);
        memset(pre, 0, sizeof(pre));
        for(int i = 0; i < n; i++) len[i] = 1;
        for(int i = 1; i < n; i++)
        {
            for(int j = 0; j < i; j++)
            {
                if(data[j].w != data[i].w && data[j].s > data[i].s)
                {
                    int tmpLen = len[j] + 1;
                    if(tmpLen > len[i])
                    {
                        len[i] = tmpLen;
                        pre[i] = j;
                    }
                }
            }
        }
        int index = 0;
        for(int i = 1; i < n; i++)
            if(len[i] > len[index]) index = i;
        cout << len[index] << endl;
        print(index);
        return 0;
    }
    


  • 相关阅读:
    BF3,MW3,CF,高端?亲民
    关于#ifdef __cplusplus extern
    lua源码阅读顺序
    (ZZ)如何实现游戏主循环(Game Loop)的详细解析
    D3D学习总结基础篇(二)从古墓丽影的画面设置了解基础概念
    比较两个json是否相等
    IPAD点滴 WebIM
    Remoting与Font对象 WebIM
    使用android隐藏api实现亮度调节
    symbian的HTTP引擎中对302、301事件的处理
  • 原文地址:https://www.cnblogs.com/im0qianqian/p/5989433.html
Copyright © 2020-2023  润新知