• All in All UVA


    You have devised a new encryption technique which encodes a message by inserting between its characters
    randomly generated strings in a clever way. Because of pending patent issues we will not discuss in
    detail how the strings are generated and inserted into the original message. To validate your method,
    however, it is necessary to write a program that checks if the message is really encoded in the final
    string.
    Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove
    characters from t such that the concatenation of the remaining characters is s.
    Input
    The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII
    characters separated by whitespace. Input is terminated by EOF.
    Output
    For each test case output, if s is a subsequence of t.
    Sample Input
    sequence subsequence
    person compression
    VERDI vivaVittorioEmanueleReDiItalia
    caseDoesMatter CaseDoesMatter
    Sample Output
    Yes
    No
    Yes
    No

    #include <iostream>
    #include<cstring>
    #include <iomanip>
    #include<string>
    using namespace std;
    int main()
    {
    char a[100000], b[100000];
    while (cin>>a>>b)
    {
    int len1 = strlen(a);
    int len2 = strlen(b);
    int i = 0, j = 0;
    while (i<len1&&j<len2)
    {
    if (a[i] == b[j])
    {
    i++;
    j++;
    }
    else { j++; }
    }
    if (i == len1)cout << "Yes" << endl;
    else cout << "No" << endl;
    }
    }
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    思路:把两者的长度记录,比较,如果i的数值与长度相同,那么说明a所有字符在b可找到,注意,数组开始值为0,最后i++后刚好为长度
    ---------------------

  • 相关阅读:
    大数据架构资料
    SQLServer 随机生成指定范围的日期
    源码解析Django CBV的本质
    源码剖析Django REST framework的认证方式及自定义认证
    Django----中间件详解
    权限管理系统
    Django---分页器、中间件
    linux每日命令(37):top命令
    linux每日命令(36):wc命令
    linux每日命令(35):grep命令
  • 原文地址:https://www.cnblogs.com/hyhy904/p/11161451.html
Copyright © 2020-2023  润新知