• POJ


    Description

    Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall. 
    Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible. 

    Input

    The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

    Output

    For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

    Sample Input

    5 5
    2 2 5
    3 2 3 4
    2 1 5
    3 1 2 5
    1 2 
    

    Sample Output

    4

    //KM模板
    #include<iostream>
    #include<cstdio>
    #include<string>
    #include<cstring>
    #include<algorithm>
    #include<vector>
    #include<stack>
    #define ll long long
    using namespace std;
    const int MAXN = 510;
    ll read() {
        ll x=0,f=1;
        char ch=getchar();
        while(!(ch>='0'&&ch<='9')) {
            if(ch=='-')f=-1;
            ch=getchar();
        };
        while(ch>='0'&&ch<='9') {
            x=x*10+(ch-'0');
            ch=getchar();
        };
        return x*f;
    }
    int uN,vN;//u,v ???,????????
    int g[MAXN][MAXN];//????
    int linker[MAXN];
    bool used[MAXN];
    bool dfs(int u) {
        for(int v = 1; v <= vN; v++)
            if(g[u][v] && !used[v]) {
                used[v] = true;
                if(linker[v] == -1 || dfs(linker[v])) {
                    linker[v] = u;
                    return true;
                }
            }
        return false;
    }
    int hungary() {
        int res = 0;
        memset(linker,-1,sizeof(linker));
        for(int u = 1; u <= uN; u++) {
            memset(used,false,sizeof(used));
            if(dfs(u))res++;
        }
        return res;
    }
    int main() {
        while(scanf("%d%d",&uN,&vN) == 2) {
            int tt,vv,ans;
            memset(g,0,sizeof(g));
            for(int i = 1; i <= uN; i++) {
                tt = read();
                for(int j = 1; j <= tt; j++) {
                    vv = read();
                    g[i][vv] = 1;
                }
    
            }
            ans = hungary();
            /*for(int i = 1;i <= 5;i++) cout<<linker[i]<<" ";
            cout<<endl;*/
            cout<<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    求所有科目都大于80分的学生姓名
    sql server如何设置密码过期时间呢?
    sql server官网使用查找技术文档(msdn、联机丛书)
    【版本特性】sql server2014版本特性
    SQLSERVER文件组误脱机后如何联机
    sql server2014中的内存优化表/内存表(续写)
    JNI日志调试LOG和中文乱码
    JNI常见错误整理
    什么是“软解码”,什么又是“硬解码”呢?
    创建eclipse针对NDK的联合编译环境。
  • 原文地址:https://www.cnblogs.com/hyfer/p/9476685.html
Copyright © 2020-2023  润新知