• fzoj1314 You are my brother


    题目描述

    Little A gets to know a new friend, Little B, recently. One day, they realize that they are family 500 years ago. Now, Little A wants to know whether Little B is his elder, younger or brother.

     

    输入

    There are multiple test cases.

    For each test case, the first line has a single integer, n (n<=1000). The next n lines have two integers a and b (1<=a,b<=2000) each, indicating b is the father of a. One person has exactly one father, of course. Little A is numbered 1 and Little B is numbered 2.

    Proceed to the end of file.

    输出

    For each test case, if Little B is Little A’s younger, print “You are my younger”. Otherwise, if Little B is Little A’s elder, print “You are my elder”. Otherwise, print “You are my brother”. The output for each test case occupied exactly one line.

     

    样例输入

    5
    1 3
    2 4
    3 5
    4 6
    5 6
    6
    1 3
    2 4
    3 5
    4 6
    5 7
    6 7

    样例输出

    You are my elder
    You are my brother

    #include<iostream>
    #include<cstring>
    using namespace std;
    int main()
    {
        int n;
        while(cin>>n)
        {
            int a,b,la=1,lb=2,da=0,db=0;
            for(int i=1;i<=n;i++)
            {
                cin>>a>>b;
                if(la==a){la=b;da++;}
                if(lb==a){lb=b;db++;}
            }
            if(db<da)cout<<"You are my elder"<<endl;
            else if(db==da) cout<<"You are my brother"<<endl;
            else if(db>da) cout<<"You are my younger"<<endl;
        }
        return 0;
    }
  • 相关阅读:
    【LVS 】NAT方式实现过程
    【 LVS 】类型及算法
    [ 总结 ] RHEL6/Centos6 使用OpenLDAP集中管理用户帐号
    [ 手记 ] 关于tomcat开机启动设置问题
    [ 总结 ] nginx 负载均衡 及 缓存
    Mac
    Swift
    Swift
    Cocoapods
    Swift
  • 原文地址:https://www.cnblogs.com/hyfer/p/5878078.html
Copyright © 2020-2023  润新知