• poj 3041 (水题)


    https://vjudge.net/problem/POJ-3041

    Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

    Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

    Input

    * Line 1: Two integers N and K, separated by a single space.
    * Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

    Output

    * Line 1: The integer representing the minimum number of times Bessie must shoot.

    Sample Input

    3 4
    1 1
    1 3
    2 2
    3 2
    

    Sample Output

    2
    

    Hint

    INPUT DETAILS:
    The following diagram represents the data, where "X" is an asteroid and "." is empty space:
    X.X
    .X.
    .X.


    OUTPUT DETAILS:
    Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
     
     
    题意:

                行与行之间相互独立,一个行可以就炸掉很多列。(列的道理一样),如果替换一些字。

                   点与点之间相互独立,一个点就可以炸掉很多边。

     
     
     
     
    思路就是上图
    代码:
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    #include<queue>
    #include<set>
    #include<algorithm>
    #include<map>
    #define maxn 2005
    typedef long long ll;
    #define inf 10000009
    using namespace std;
    int n,k;
    int zzz,x,y;
    bool can[maxn][maxn];//can[][]表示计算机i能够处理的任务
    struct edge{
       int to,cap,rev;    //边的终点,容量,反向边
    };
    vector<edge>mp[maxn];  // 邻接图
    bool vis[maxn];
    void add_edge(int from,int to,int cap)   //建图
    {
        mp[from].push_back((edge){to,cap,mp[to].size()});
         mp[to].push_back((edge){from,0,mp[from].size()-1});  //反向弧
    }
    int dfs(int v,int t,int f)   //找增广路 v,t是最终点  用了f的流量
    {
       if(v==t)return f;
       vis[v]=true;
       for(int i=0;i<mp[v].size();i++)
       {
           edge &e=mp[v][i];
           if(!vis[e.to]&&e.cap>0)
           {
               int d=dfs(e.to,t,min(f,e.cap));  //遍历所有的路径
               if(d>0)
               {
                   e.cap-=d;                    //求增加的流量
                   mp[e.to][e.rev].cap+=d;
                   return d;
               }
           }
       }
       return 0;
    }
    int max_flow(int s,int t)
    {
        int flow=0;
        for(;;)
        {
            memset(vis,0,sizeof(vis));   //初始化
            int f=dfs(s,t,inf);
            if(f==0)return flow;
            flow+=f;
        }
    }
    void solve()
    {
        int s=n+n+1;
        int t=s+1;
        for(int i=0;i<n;i++)
        {
            add_edge(s,i,1);
        }
        for(int i=0;i<n;i++)
        {
            add_edge(n+i,t,1);
        }
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                if(can[i][j]==1)
                {
                    //cout<<i<<" "<<j;
                   add_edge(i,n+j,1);
                }
            }
        }
        cout<<max_flow(s,t)<<endl;
    }
    int main()
    {
        while(cin>>n>>k)
        {
            memset(can,0,sizeof(can));
            for(int i=0;i<k;i++)
            {
                cin>>x>>y;
                x--;
                y--;
              can[x][y]=1;
            }
            solve();
        }
        return 0;
    }
     
  • 相关阅读:
    JavaAndroid项目结构
    Python 常用系统模块整理
    Python 部分系统类的常用方法整理
    xpath语法笔记
    xml笔记
    Python 内置函数笔记
    剑指Offer-二叉搜索树的第k个结点
    Java中Set集合是如何实现添加元素保证不重复的?
    剑指Offer-链表中倒数第k个结点
    Leetcode#1.Two Sum(两数之和)
  • 原文地址:https://www.cnblogs.com/huangzzz/p/9459196.html
Copyright © 2020-2023  润新知