• 简单并查集2 poj1611


    真的是自己写的哦!

    题目:https://vjudge.net/contest/182418#problem/B

    B - The Suspects

    POJ - 1611 

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
    Once a member in a group is a suspect, all members in the group are suspects.
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

    Sample Output

    4
    1
    1

    题意:
    有N个学生,分成m个组(一个学生可以分别进入多个组)
    分别输入m个组的成员个数k和成员
    只要是每组中有一个人得了传染病那么整个组都会有传染病
    思路:

                基本并查集模板,加入个数处理直接返回就ok

    代码:

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    #include<queue>
    #include<set>
    #include<algorithm>
    #include<map>
    #define maxn 100005
    using namespace std;
    int fa[maxn],rank[maxn];
    void init(int n)
    {
        for(int i=0;i<n;i++)
        {
            fa[i]=i;
            rank[i]=1;
        }
    }
    int find(int x)
    {
        if(fa[x]==x)return x;
        else{
            return fa[x]=find(fa[x]);
        }
    }
    void unite(int x,int y)
    {
        x=find(x);
        y=find(y);
        if(x==y)return ;
        if(x!=y)
        {
            fa[x]=y;
            rank[y]+=rank[x];
        }
        /*if(rank[x]<rank[y])
        {
            fa[x]=y;
            rank[x]+=rank[y];
        }
        else{
            fa[y]=x;
            rank[y]+=rank[x];
           // if(rank[x]==rank[y])rank[x]++;
        }
        */
    }
    int main()
    {
        int n,m,k;
        int s[maxn];
        while(cin>>n>>m){
        init(n);
        if(n==0&&m==0)return 0;
        while(m--)
        {
           cin>>k;
           for(int i=0;i<k;i++)
           {
               cin>>s[i];
           }
           for(int i=0;i<k-1;i++)
           {
               unite(s[i],s[i+1]);
           }
        }
        int t=find(0);
        cout<<rank[t]<<endl;
        }
        return 0;
    }

    PS:
    代码很简单,思路清晰就ojbk,,

  • 相关阅读:
    网络基础 HTTP协议之http url简介
    MySql 简单统计查询消耗时间脚本
    Java java jdk在Linux下安装与环境变量的配置
    MySql 正则表达式简介及使用
    MySql UNIX_TIMESTAMP和FROM_UNIXTIME函数讲解
    MySql 定时任务的使用
    MySql 利用crontab实现MySql定时任务
    MySql 利用mysql&mysqldum导入导出数据
    排错-windows平台下访问oracle em出现空白的解决方法
    Oracle 修改oracle数据库名
  • 原文地址:https://www.cnblogs.com/huangzzz/p/7989789.html
Copyright © 2020-2023  润新知