• 图论2 去点+dij


    被虐了一下午补的题

    题目: http://hdu.hustoj.com/showproblem.php?pid=5137

    How Many Maos Does the Guanxi Worth

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
    Total Submission(s): 3198    Accepted Submission(s): 1249


    Problem Description
    "Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with you." or "The guanxi between them is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.

    Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will be accepted by the middle school. Of course, all helpers including the schoolmaster are paid by Boss Liu.

    You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you can't make Boss Liu fail, you want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.
     
    Input
    There are several test cases.

    For each test case:

    The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu's guanxi net. (3 <=N <= 30, 3 <= M <= 1000)

    Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

    The input ends with N = 0 and M = 0.

    It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.
     
    Output
    For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.
     
    Sample Input
    4 5
    1 2 3
    1 3 7
    1 4 50
    2 3 4
    3 4 2
    3 2
    1 2 30
    2 3 10
    0 0
     
    Sample Output
    50
    Inf
     
     
    题意:去点求最短路径的最大值
     
    题解:去点,枚举,迪杰斯特拉求最短路
    代码:
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    #include<queue>
    #include<set>
    #include<algorithm>
    #include<map>
    #define maxn 10005
    #define inf 0x3f3f3f3f
    using namespace std;
    int mp[maxn][maxn];
    int dis[maxn],qu[maxn];
    bool vis[maxn];
    void dijkstra(int n)
    {
        memset(vis,false,sizeof(vis));
        for(int i=1;i<=n;i++)
        {
            dis[i]=mp[1][i];
        }
        dis[1]=0;
        for(int i=1;i<=n;i++)
        {
            int top=inf;
            int k;
            for(int j=1;j<n;j++)
            {
                if(!vis[j]&&dis[j]<top){
                top=dis[j];
                k=j;
                }
            }
        vis[k]=true;
        for(int j=1;j<=n;j++)//枚举更新点
        {
            if(!vis[j]&&dis[j]>dis[k]+mp[k][j])
            {
                dis[j]=dis[k]+mp[k][j];
            }
        }
        }
    }
    int main()
    {
        int n,m,u,v,x;
        while(cin>>n>>m)
        {
            if(m==0||n==0)return 0;
            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
            {
                if(i==j)mp[i][j]=0;
                else mp[i][j]=inf;
            }
            for(int i=1;i<=m;i++)
            {
                cin>>u>>v>>x;
                if(mp[u][v]>x){
                mp[u][v]=x;
                mp[v][u]=x;
                }
            }
            int ans=0;
            for(int i=2;i<n;i++)
            {
                for(int j=1;j<=n;j++)
                {
                    qu[j]=mp[i][j];
                    mp[i][j]=mp[j][i]=inf;
                }
                dijkstra(n);
                if(ans<dis[n])
                {
                    ans=dis[n];
                }
                for(int j=1;j<=n;j++)
                {
                    mp[i][j]=mp[j][i]=qu[j];
                }
            }
            if(ans==inf)cout<<"Inf"<<endl;
            else cout<<ans<<endl;
        }
        return 0;
    }

    ,题目简单,写博客只是为了复习

  • 相关阅读:
    机器学习介绍
    Day03 作业
    Python函数基础
    Python练习
    耳机 线控 控制播放
    edittext 底线颜色
    从service启动activity startActivity慢 的解决方案
    国产手机没有google services 和google play崩溃,判断google services是否存在
    检测耳机插入和拔出
    获取view宽高
  • 原文地址:https://www.cnblogs.com/huangzzz/p/7900029.html
Copyright © 2020-2023  润新知