• Guangsoushensou 2


    <span style="color:#330099;">/*
    C - 广搜 基础
    Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
    Submit
     
    Status
    Description
    A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy. 
    Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 
    
    Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.
    Input
    The input will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.
    Output
    For each test case, print one line saying "To get from xx to yy takes n knight moves.".
    Sample Input
    e2 e4
    a1 b2
    b2 c3
    a1 h8
    a1 h7
    h8 a1
    b1 c3
    f6 f6
    Sample Output
    To get from e2 to e4 takes 2 knight moves.
    To get from a1 to b2 takes 4 knight moves.
    To get from b2 to c3 takes 2 knight moves.
    To get from a1 to h8 takes 6 knight moves.
    To get from a1 to h7 takes 5 knight moves.
    To get from h8 to a1 takes 6 knight moves.
    To get from b1 to c3 takes 1 knight moves.
    To get from f6 to f6 takes 0 knight moves.
    By Grant Yuan
    2014.7.12
    */
    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    #include<queue>
    #include<cstdio>
    using namespace std;
    bool flag[21][21];
    char a[21][21];
    int n,m;
    int s1,f1;
    typedef struct{
       int x;
       int y;
    }node;
    int next[4][2]={1,0,0,1,-1,0,0,-1};
    int sum;
    node q[10000];
    int top,base;
    bool can(int cc,int dd)
    {
        if(cc>=0&&cc<m&&dd>=0&&dd<n&&flag[cc][dd]==0)
          return 1;
        return 0;
    }
    
    void slove()
    {  int c,d,cc,dd;
       node q1;
        while(top>=base){
        // c=q.front().x;d=q.front().y;
        c=q[base].x; d=q[base].y;
          for(int i=0;i<4;i++)
            {
                cc=c+next[i][0];
                dd=d+next[i][1];
                if(can(cc,dd))
                  {   q1.x=cc;
                      q1.y=dd;
                     // cout<<cc<<" "<<dd<<endl;
                      //q.push(q1);
                      q[++top]=q1;
                      flag[cc][dd]=1;
                      sum++;
                  }
            }
            //q.pop();
            base++;
           }
    }
    
    int main()
    {  node q1;
        while(1){
            sum=1;
            top=-1;base=0;
         memset(flag,0,sizeof(flag));
         cin>>n>>m;
         if(n==0&&m==0)
            break;
         for(int i=0;i<m;i++){
            // cout<<"zhang"<<endl;
           scanf("%s",&a[i]);}
          //  for(int i=0;i<m;i++)
           // puts(a[i]);
            /*for(int i=0;i<m;i++)
             puts(a[i]);*/
         for(int i=0;i<m;i++)
           for(int j=0;j<n;j++)
             {if(a[i][j]=='#')
                 flag[i][j]=1;
    
             if(a[i][j]=='@')
                   s1=i,f1=j;
             }
            q1.x=s1;
            q1.y=f1;
            flag[s1][f1]=1;
           // for(int i=0;i<m;i++)
          // for(int j=0;j<n;j++){
          // cout<<flag[i][j];
          // if(j==n-1) cout<<endl;}
            //q.push(q1);
            q[++top]=q1;
            slove();
            cout<<sum<<endl;
             }
             return 0;
    }
    </span>

    版权声明:本文博主原创文章,博客,未经同意不得转载。

  • 相关阅读:
    sql语句开发使用---update
    获取弹出框的句柄,关闭弹出框
    水晶报表使用,解决相同数据库不同服务器使用同一个水晶报表模板问题?
    第一章 什么是SQL Server Integration Services (ssis) 系统。
    在 win 10 中使用sql 2012 附加低版本数据失败的解决办法。
    窗体间传值 委托应用
    有点小激动
    Adam
    SVN Unable to connect to a repository at URL问题解决
    C#基础---IComparable用法,实现List<T>.sort()排序
  • 原文地址:https://www.cnblogs.com/hrhguanli/p/4907710.html
Copyright © 2020-2023  润新知