• UVA 10494-If We Were a Child Again(一流的塔尔苏斯)


    Problem C
    If We Were a Child Again

    Input: standard input
    Output: standard output

    Time Limit: 7 seconds

     

    “Oooooooooooooooh!

    If I could do the easy mathematics like my school days!!

    I can guarantee, that I’d not make any mistake this time!!”

    Says a smart university student!!

    But his teacher even smarter – “Ok! I’d assign you such projects in your software lab. Don’t be so sad.”

    “Really!!” - the students feels happy. And he feels so happy that he cannot see the smile in his teacher’s face.

     

    The Problem

     

    The first project for the poor student was to make a calculator that can just perform the basic arithmetic operations.

     

    But like many other university students he doesn’t like to do any project by himself. He just wants to collect programs from here and there. As you are a friend of him, he asks you to write the program. But, you are also intelligent enough to tackle this kind of people. You agreed to write only the (integer) division and mod (% in C/C++) operations for him.

     

    Input

    Input is a sequence of lines. Each line will contain an input number. One or more spaces. A sign (division or mod). Again spaces. And another input number. Both the input numbers are non-negative integer. The first one may be arbitrarily long. The second number n will be in the range (0 < n < 231).

     

     
    Output

    A line for each input, each containing an integer. See the sample input and output. Output should not contain any extra space.

     

     
     
    Sample Input

    110 / 100

    99 % 10

    2147483647 / 2147483647

    2147483646 % 2147483647

     

     

     

     

     
     
    Sample Output

    1

    9

    1

    2147483646

     


    第一次用java写,曾经从来没看过,今天看了一点主要的输入输出切了一道A+B后,直接来一道高精度的。1A得意,没有编译器,直接敲完就交,谁给我的勇气?。。。

    待会写一篇总结java里面的高精度大数的使用方法


    import java.io.*;
    
    import java.util.*;
    
    import java.math.*;
    import java.text.*;
    public class Main {
    
    		public static void main(String args[]) {
    
    		       Scanner in = new Scanner(System.in);
    
                           BigInteger a,b;char c;
                           while(in.hasNext()){
    		       a = in.nextBigInteger();
    
                           c=in.next().charAt(0);
    		       b = in.nextBigInteger();
    
    
    		       if(c=='/')
                           System.out.println(a.divide(b));
                           else
                            System.out.println(a.mod(b));
                           
                          }
    		
                   }
    
    }
    


    版权声明:本文博客原创文章。博客,未经同意,不得转载。

  • 相关阅读:
    ethtool 命令输出的注意点--网卡参数
    centos7.2+zabbix3.2+sedmail邮件告警
    vscode monokai
    SQL SERVER 常用命令
    数据库问题6-將系統資料表對應至系統檢視
    数据库问题5-SYS.SYSPROCESSES使用和查找死锁
    select * from sys.sysprocesses
    【SQL Server学习笔记】事务、锁定、阻塞、死锁 sys.sysprocesses
    使用DMV调优性能 --Burgess_Liu
    sql server线程等待信息
  • 原文地址:https://www.cnblogs.com/hrhguanli/p/4732457.html
Copyright © 2020-2023  润新知