• UVA 10608 Friends


    Friends(8.4.1)
    Crawling in process...Crawling failedTime Limit:3000MS    Memory Limit:0KB     64bit IO Format:%lld & %llu

    Description


    There is a town with N citizens. It is known that some pairs of people are friends. According to the famous saying that “The friends of my friends are my friends, too” it follows that if A and B are friends and B and C are friends then A and C are friends, too.

    Your task is to count how many people there are in the largest group of friends.

    Input

    Input consists of several datasets. The first line of the input consists of a line with the number of test cases to follow. The first line of each dataset contains tho numbers N and M, where N is the number of town's citizens (1≤N≤30000) and M is the number of pairs of people (0≤M≤500000), which are known to be friends. Each of the following M lines consists of two integers A and B (1≤A≤N, 1≤B≤N, A≠B) which describe that A and B are friends. There could be repetitions among the given pairs.

    Output

    The output for each test case should contain one number denoting how many people there are in the largest group of friends.

    Sample Input

    Sample Output

    2

    3 2

    1 2

    2 3

    10 12

    1 2

    3 1

    3 4

    5 4

    3 5

    4 6

    5 2

    2 1

    7 10

    1 2

    9 10

    8 9

    3

    6


    #include <iostream>
    #include <cstring>
    #define maxn 30005
    using namespace std;
    int f[maxn],ans[maxn];
    int find(int x)
    {
        if(f[x]==x)
            return x;
        else
            return(f[x]=find(f[x]));	 
    }
    int main()
    {
        int N;
    	cin>>N;
        while(N--)
        { 
    		int n,m;
    		cin>>n>>m;
    		
    		int i;
    		for(i=1;i<=n;i++)
    			f[i]=i;
    		
    		memset(ans,0,sizeof(ans));
    		
    		for(i=1;i<=m;i++)
    		{
    			int x,y;
    			cin>>x>>y;
    			int fx,fy;
    			fx=find(x);
    			fy=find(y);
    			if(fx!=fy)
    				f[fx]=fy;
    		}
    		
    		for(i=1;i<=n;i++)
    			ans[find(i)]++;
    		
    		int max=0;
    		for(i=1;i<=n;i++)
    			if(ans[i]>max)
    				max=ans[i];
    			
    			cout<<max<<endl;
        }
        return 0;
    }
    


    代码还没有ac。不管是在UVA上还是虚拟oj上都显示,In judge queue

    表示非常无语,等了好长时间,虚拟oj显示  Judging Error 2。淡淡的忧桑。



    更新:已经ac


    版权声明:本文博客原创文章,博客,未经同意,不得转载。

  • 相关阅读:
    sql server 笔记(数据类型/新建、修改、删除数据表/)
    在与 SQL Server 建立连接时出现与网络相关的或特定于实例的错误。未找到或无法访问服务器。请验证实例名称是否正确并且 SQL Server 已配置为允许远程连接。 (provider: Nam
    jquery 操作 checkbox select
    layui常见问题
    Sublime Text 3下载-汉化-插件配置
    CSS前端开发学习总结、一
    如何用 JavaScript 下载文件
    腾讯大王卡、天王卡代申请
    新人报道~cnblogs
    Node.js
  • 原文地址:https://www.cnblogs.com/hrhguanli/p/4621816.html
Copyright © 2020-2023  润新知