• poj1163The Triangle(简单DP)


    转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents

    题目链接:http://poj.org/problem?id=1163

    ----------------------------------------------------------------------------------------------------------------------------------------------------------
    欢迎光临天资小屋害羞害羞害羞害羞http://user.qzone.qq.com/593830943/main
    
    
    ----------------------------------------------------------------------------------------------------------------------------------------------------------


    Description

    7
    3   8
    8   1   0
    2   7   4   4
    4   5   2   6   5
    
    (Figure 1)
    Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

    Input

    Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

    Output

    Your program is to write to standard output. The highest sum is written as an integer.

    Sample Input

    5
    7
    3 8
    8 1 0 
    2 7 4 4
    4 5 2 6 5

    Sample Output

    30

    简单DP例如以下:

    #include <iostream>
    #include <cstring>
    using namespace std;
    
    int n;
    int dp[117][117];
    void DP(int dp[117][117])
    {
    	int i, j;
    	for(i = n-1; i >= 0; i--)
    	{
    		for(j = 1; j <= i; j++)
    		{
    			dp[i][j]+=max(dp[i+1][j],dp[i+1][j+1]);
    		}
    	}
    }
    int main()
    {
    	int i, j;
    	while(cin >> n)
    	{
    		for(i = 1; i <= n; i++)
    		{
    			for(j = 1; j <= i; j++)
    			{
    				cin>>dp[i][j];
    			}
    		}
    		DP(dp);
    		cout<<dp[1][1]<<endl;
    	}
    	return 0;
    }


  • 相关阅读:
    [NOIP2011提高组]聪明的质监员
    NOIP 2010 关押罪犯
    题目:埃及分数
    用scanf输入long long 型的数
    poj 1014 Dividing
    Cactus
    SQLite数据库的增删改查代码
    UltraGrid常用方法属性代码
    维护数据表常用SQL语句
    C#备份收藏夹代码
  • 原文地址:https://www.cnblogs.com/hrhguanli/p/4560570.html
Copyright © 2020-2023  润新知