• PAT Advanced 1126 Eulerian Path (25) [连通图,欧拉路径,欧拉回路,欧拉图]


    题目

    In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path ) Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.
    Input Specification:
    Each input file contains one test case. Each case starts with a line containing 2 numbers N (<= 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).
    Output Specification:
    For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph — either “Eulerian”, “Semi-Eulerian”, or “NonEulerian”. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.
    Sample Input 1:
    7 12
    5 7
    1 2
    1 3
    2 3
    2 4
    3 4
    5 2
    7 6
    6 3
    4 5
    6 4
    5 6
    Sample Output 1:
    2 4 4 4 4 4 2
    Eulerian
    Sample Input 2:
    6 10
    1 2
    1 3
    2 3
    2 4
    3 4
    5 2
    6 3
    4 5
    6 4
    5 6
    Sample Output 2:
    2 4 4 4 3 3
    Semi-Eulerian
    Sample Input 3:
    5 8
    1 2
    2 5
    5 4
    4 1
    1 3
    3 2
    3 4
    5 3
    Sample Output 3:
    3 3 4 3 3
    Non-Eulerian

    题目分析

    欧拉通路(路径Eulerian trail/Eulerian Path): 如果图G中的一个路径包括每个边恰好一次,则该路径称为欧拉路径
    欧拉回路(Eulerian circuit): 如果一个回路是欧拉路径,则称为欧拉回路
    欧拉图(Eulerian):包含欧拉回路的图
    半欧拉图(semi-Eulerian):包含欧拉路径,但不包含欧拉回路的图

    已知一系列图,求是否为欧拉图,若为欧拉图判断是否为半欧拉图

    解题思路

    欧拉图条件:

    1. 图连通
    2. 所有顶点度为2

    半欧拉图条件:

    1. 图连通
    2. 图有2个顶点为奇数度(即:有欧拉路径,无欧拉回路)

    Code

    #include <iostream>
    #include <vector>
    using namespace std;
    const int maxn=510;
    vector<int> eg[maxn];
    int n,m,cnt=0,even=0,vis[maxn];
    void dfs(int v){
    	vis[v]=1;
    	cnt++; //统计顶点数
    	for(int i=0;i<eg[v].size();i++){
    		if(vis[eg[v][i]]==false){
    			dfs(eg[v][i]); 
    		}
    	} 
    }
    int main(int argc,char * argv[]) {
    	scanf("%d %d",&n,&m);
    	int a,b;
    	for(int i=0; i<m; i++) {
    		scanf("%d %d",&a,&b);
    		eg[a].push_back(b);
    		eg[b].push_back(a);
    	}
    	for(int i=1; i<=n; i++) {
    		printf("%d",eg[i].size());
    		printf("%s",i!=n?" ":"
    ");
    		if(eg[i].size()%2==0)even++;
    	}
    	dfs(1);
    	if(even==n&&cnt==n){
    		//顶点都是偶数度,且连通 
    		printf("Eulerian");
    	}else if(even==n-2&&cnt==n){
    		//2个顶点为奇数度,其余都是偶数度,且连通
    		printf("Semi-Eulerian");
    	}else{
    		printf("Non-Eulerian");
    	}
    	return 0;
    }
    

  • 相关阅读:
    软件开发项目文档模版
    Java Swing 非常漂亮的外观Nimbus使用方法
    周00王总监 宁波浦一的同仁们 有看见的进来
    冰川世界
    君住长江头,我住长江尾,日日思君不见君,共饮长江水
    可乐男孩被保送上大学
    变形金刚2
    爱无罪
    英语习惯口语简写
    看完了团长,我没有心理在去看《南京!南京!》
  • 原文地址:https://www.cnblogs.com/houzm/p/12384843.html
Copyright © 2020-2023  润新知