• PAT Advanced 1099 Build A Binary Search Tree (30) [⼆叉查找树BST]


    题目

    A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

    • The left subtree of a node contains only nodes with keys less than the node's key.
    • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
    • Both the left and right subtrees must also be binary search trees.

    Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
    Input Specification:
    Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.
    Output Specification:
    For each test case, print in one line the level order traversal sequence of that tree. All the numbers must
    be separated by a space, with no extra space at the end of the line.
    Sample Input:
    9
    1 6
    2 3
    -1 -1
    -1 4
    5 -1
    -1 -1
    7 -1
    -1 8
    -1 -1
    73 45 11 58 82 25 67 38 42
    Sample Output:
    58 25 82 11 38 67 45 73 42

    题目分析

    已知二叉查找树的所有非叶子节点的子节点信息,求其层序序列

    解题思路

    思路 01

    1. 用二维数组存储所有节点关系,将二叉查找树节点任意序列升序排序即为中序序列
    2. 建树(左右指针)
    3. 中序序列打印模拟过程,设置所有节点值信息
    4. 借助队列,实现层序遍历

    思路 02

    1. 用节点数组建树(类似静态数组)
    2. 模拟中序序列打印过程,设置所有节点值信息,并记录index(index=i节点的子节点index为2i+1,2i+2(root存放在0下标)),level记录节点所在层
    3. 用index和level对节点数组排序
    4. 打印节点数组,即为层序序列

    Code

    Code 01

    #include <iostream>
    #include <algorithm>
    #include <queue>
    using namespace std;
    const int maxn=100;
    int n,cnt=0,in[maxn],nds[maxn][2];
    struct node {
    	int data;
    	node * left=NULL;
    	node * right=NULL;
    	node() {}
    	node(int _data):data(_data) {}
    };
    node * inOrder(int index) {
    	if(index==-1) {
    		return NULL;
    	}
    	node * root = new node();
    	root->left=inOrder(nds[index][0]);
    	root->data = in[cnt++];
    	root->right=inOrder(nds[index][1]);
    	return root;
    }
    void levelOrder(node * root){
    	queue<node*> q;
    	q.push(root);
    	int index = 0;
    	while(!q.empty()){
    		node * now = q.front();
    		q.pop();
    		printf("%d",now->data);
    		if(++index<n)printf(" "); 
    		if(now->left!=NULL)q.push(now->left);
    		if(now->right!=NULL)q.push(now->right);
    	}
    }
    int main(int argc,char * argv[]) {
    	scanf("%d",&n);
    	int f,r;
    	for(int i=0; i<n; i++) {
    		scanf("%d %d",&f, &r);
    		nds[i][0]=f;
    		nds[i][1]=r;
    	}
    	for(int i=0; i<n; i++) scanf("%d",&in[i]);
    	sort(in,in+n);
    	node * root = inOrder(0);
    	levelOrder(root);
    	return 0;
    }
    

    Code 02(最优)

    #include <iostream>
    #include <algorithm>
    #include <queue>
    using namespace std;
    const int maxn=100;
    int n,cnt=0,in[maxn];
    struct node {
    	int data;
    	double index=-1; //最坏情况,每一层一个节点,index最大为2^100 ,测试使用long long也有两个测试点不通过
    	int left=-1;
    	int right=-1;
    	node() {}
    	node(int _data):data(_data) {}
    	node(int _left, int _right) {
    		left=_left;
    		right=_right;
    	}
    }nds[maxn];
    void inOrder(int root, double index) {
    	if(root==-1) {
    		return;
    	}
    	inOrder(nds[root].left,2*index+1);
    	nds[root].index=index;
    	nds[root].data=in[cnt++];
    	inOrder(nds[root].right,2*index+2);
    }
    bool cmp(node &n1,node &n2){
    	return n1.index<n2.index;
    }
    int main(int argc,char * argv[]) {
    	scanf("%d",&n);
    	int f,r;
    	for(int i=0; i<n; i++) {
    		scanf("%d %d",&nds[i].left, &nds[i].right);
    	}
    	for(int i=0; i<n; i++) scanf("%d",&in[i]);
    	sort(in,in+n);
    	inOrder(0,0);
    	sort(nds,nds+n,cmp);
    	for(int i=0;i<n;i++){
    		if(i!=0)printf(" ");
    		printf("%d",nds[i].data);
    	}
    	return 0;
    }
    
  • 相关阅读:
    【转】汽车CAN总线
    【转】I2C总线协议
    【转】SPI总线协议
    【转】结构struct 联合Union和枚举Enum的细节讨论
    复合类型变量其首地址的几种表示方式
    【转】四款经典3.7v锂电池充电电路图详解
    【转】crc16几种标准校验算法及c语言代码
    【转】 CRC循环冗余校验码
    对STM32库函数中 assert 函数的认知
    【转】用宏定义代替printf函数
  • 原文地址:https://www.cnblogs.com/houzm/p/12333843.html
Copyright © 2020-2023  润新知