• Common Subsequence 最大公共子序列问题


    Problem Description
    A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
    The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
     
    Sample Input
    abcfbc abfcab programming contest abcd mnp
     
    Sample Output
    4 2 0
     
     
     
     
    关键点:要掌握问题的转化,关键点是要理解,假设序列 X={X1,X2...Xm}和Y={Y1,Y2,...Yn}的最长公共子序列为Z={Z1,Z2...Zk)
    (1)若Xm = Yn 则 Zk=Xm=Yn ,且Zk-1 是Xm-1 和 Yn-1的最长公共子序列
    (2)若Xm 不等于Yn,且Zk不等于Xm 则Z是Xm-1和Y的最长公共子序列
    (3)若Xm不等于Yn,且Zk不等于Yn 则Z是X和Yn-1 的最长公共子序列
     

    #include<stdio.h>
    #include<string.h>
    int c[500][500],lena,lenb;
    int max(int a,int b){
    if(a>=b)
    return a;
    else
    return b;
    }
    int main(){
    char a[500],b[500];
    while(scanf("%s%s",a,b)==2){
    lena = strlen(a);
    lenb = strlen(b);
    for(int i=0;i<lena;i++)
    c[i][0]=0;
    for(int j=0;j<lenb;j++)
    c[0][j]=0;
    for(int i=1;i<=lena;i++)
    for(int j=1;j<=lenb;j++){
    if(a[i-1]==b[j-1])//这里需要注意下,不能忘记字符a[0],b[0]的比较,所以在计算的过程中需要计算到lena
    c[i][j]=c[i-1][j-1]+1;
    else
    c[i][j]=max(c[i-1][j],c[i][j-1]);
    }
    printf("%d ",c[lena][lenb]);
    }
    return 0;
    }

     
     
  • 相关阅读:
    elementui中el-alert实现换行的方法
    Element-UI中el-table实现简单动态数据绑定的实现
    腾讯课堂多倍速、去除xxx正在观看
    Linux vim 常用操作
    尚硅谷《谷粒商城项目总结》
    Centos 安装 Harbor
    centos 7 安装 kubernetes
    Mac VirtualBox 没有 Host-Only 选项怎么设置?
    VirtualBox 安装 centos7
    ssh 使用 sed 替换的时候,替换的字符串有单双引号的时候怎么用
  • 原文地址:https://www.cnblogs.com/hoojjack/p/4014393.html
Copyright © 2020-2023  润新知