• Common Subsequence 最大公共子序列问题


    Problem Description
    A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
    The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
     
    Sample Input
    abcfbc abfcab programming contest abcd mnp
     
    Sample Output
    4 2 0
     
     
     
     
    关键点:要掌握问题的转化,关键点是要理解,假设序列 X={X1,X2...Xm}和Y={Y1,Y2,...Yn}的最长公共子序列为Z={Z1,Z2...Zk)
    (1)若Xm = Yn 则 Zk=Xm=Yn ,且Zk-1 是Xm-1 和 Yn-1的最长公共子序列
    (2)若Xm 不等于Yn,且Zk不等于Xm 则Z是Xm-1和Y的最长公共子序列
    (3)若Xm不等于Yn,且Zk不等于Yn 则Z是X和Yn-1 的最长公共子序列
     

    #include<stdio.h>
    #include<string.h>
    int c[500][500],lena,lenb;
    int max(int a,int b){
    if(a>=b)
    return a;
    else
    return b;
    }
    int main(){
    char a[500],b[500];
    while(scanf("%s%s",a,b)==2){
    lena = strlen(a);
    lenb = strlen(b);
    for(int i=0;i<lena;i++)
    c[i][0]=0;
    for(int j=0;j<lenb;j++)
    c[0][j]=0;
    for(int i=1;i<=lena;i++)
    for(int j=1;j<=lenb;j++){
    if(a[i-1]==b[j-1])//这里需要注意下,不能忘记字符a[0],b[0]的比较,所以在计算的过程中需要计算到lena
    c[i][j]=c[i-1][j-1]+1;
    else
    c[i][j]=max(c[i-1][j],c[i][j-1]);
    }
    printf("%d ",c[lena][lenb]);
    }
    return 0;
    }

     
     
  • 相关阅读:
    批量 kill mysql 线程
    ansible playbook实践(三)-yaml文件写法
    ansible playbook实践(二)-基础相关命令
    ansible playbook实践(一)-基础环境安装
    rsync源目录写法的一点小细节
    python threading queue模块中join setDaemon及task_done的使用方法及示例
    python多线程限制并发数示例
    完全总结bash中的条件判断test [ [[ 使用
    CHECK MEMBER TYPE
    C++14 make code cleaner
  • 原文地址:https://www.cnblogs.com/hoojjack/p/4014393.html
Copyright © 2020-2023  润新知