• Encoding


    Encoding

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 36852    Accepted Submission(s): 16344

    Problem Description
    Given a string containing only 'A' - 'Z', we could encode it using the following method: 

    1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

    2. If the length of the sub-string is 1, '1' should be ignored.
     
    Input
    The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
     
    Output
    For each test case, output the encoded string in a line.
     
    Sample Input
    2 ABC ABBCCC
     
    Sample Output
    ABC A2B3C
     
    注意子字符串定义:
    substring
    "abc"的substring包括"ab","bc","a"等等

    必须是连续的,如果不连续如"ac",则叫做subsequence (子序列)

    #include<iostream>
    #include<string>//这里用cstring oj编译不通过

    using namespace std;

    int main()
    {
    int caseNum=0;
    cin>>caseNum;
    while(caseNum--)
    {
    string strs;
    cin>>strs;
    int len=strs.length();
    for(int i=0;i<len;i++)
    {
    char ori=strs[i];
    if((i-1>-1)&&(strs[i]==strs[i-1]))
    {
    if(i==len-1)cout<<endl;
    continue;
    }
    int count=1;
    for(int j=i+1;j<len;j++)
    {
    if(ori!=strs[j])
    {
    break;
    }
    else
    {
    count++;
    }
    }
    if(count==1)
    {
    cout<<ori;
    }
    else
    {
    cout<<count<<ori;
    }
    if(i==len-1)cout<<endl;
    }
    }
    return 0;
    }

     
  • 相关阅读:
    SpringCloud第五天
    SpringCloud第四天
    SpringCloud第三天
    mysql数据库主从同步I/O问题修复
    linux服务器通过rpm包安装nginx案例
    potplayer最大化不遮挡任务栏
    火狐怎么在新标签打开书签
    Binding failed for port a1e67849-aa1d-418d-a04c-8343b8dbf64f, please check neutron logs for more information
    Unable to mount root fs on unknown-block(0,0)
    安装VCSA6.7
  • 原文地址:https://www.cnblogs.com/honeybusybee/p/5244358.html
Copyright © 2020-2023  润新知