• POJ-2253 Frogger( 最短路 )


    题目链接:http://poj.org/problem?id=2253

    Description

    Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
    Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
    To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
    The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

    You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

    Input

    The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

    Output

    For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

    Sample Input

    2
    0 0
    3 4
    
    3
    17 4
    19 4
    18 5
    
    0
    

    Sample Output

    Scenario #1
    Frog Distance = 5.000
    
    Scenario #2
    Frog Distance = 1.414

    题目大意:青蛙想从1号石头跳到2号石头,但是青蛙能力(一步跳的距离)有限,一下跳不过去,于是想把其他石头当跳板跳过去,问青蛙的跳跃能力最小是多少
    题目思路典型的最短路问题,将原来表示到i的最小距离的数组改为表示到i的路径中最长的一段,即到i所需的跳跃能力即可

    #include<iostream>
    #include<cstring>
    #include<algorithm>
    #include<cmath>
    #include<iomanip>
    
    using namespace std;
    
    double stone[205][2], dis[205];
    bool flag[205];
    
    double getdis( int a, int b ){
    	double dx = stone[a][0] - stone[b][0], dy = stone[a][1] - stone[b][1];
    	return sqrt( dx * dx + dy * dy );
    }
    
    int main(){
    	int n;
    	int Case = 1;
    	while( cin >> n, n ){
    		for( int i = 1; i <= n; i++ ){
    			cin >> stone[i][0] >> stone[i][1];
    			if( i == 1 ) continue;
    			dis[i] = getdis( 1, i );
    		}
    		memset( flag, true, sizeof( flag ) );
    		flag[1] = false;
    
    		for( int t = 1; t < n ; t++ ){
    			double minx = 0x3f3f3f3f;
    			int mini = 1;
    			for( int i = 2; i <= n; i++ ){
    				if( flag[i] && dis[i] < minx ){
    					minx = dis[i];
    					mini = i;
    				} 
    			}
    
    			flag[mini] = false;
    
    			for( int i = 2; i <= n; i++ ){
    				double temp = getdis( i, mini );
    				if( flag[i] && dis[i] > max( dis[mini], temp ) ){
    					dis[i] = max( dis[mini], temp );
    				}
    			}
    		}
    
    		cout << "Scenario #" << Case++ << endl;
    		cout << "Frog Distance = " << fixed << setprecision(3) << dis[2] << endl << endl;
    	}
    }
    
    
    
    

  • 相关阅读:
    Linux安全应用之防垃圾邮件服务器的构建
    Postfix邮件系统安装配置视频
    Linux常用的安全工具
    Linux系统安全加固(一)
    全球开源软件发展趋势分析
    安装配置FreeBSD9全过程体验
    P1441-砝码称重
    POJ-2376 Cleaning Shifts
    P1514-引水入城
    P1378-油滴扩展
  • 原文地址:https://www.cnblogs.com/hollowstory/p/5581928.html
Copyright © 2020-2023  润新知