• UVA 10806 Cheerleaders


                          Cheerleaders
    Description
     

    C

    Cheerleaders

    In most professional sporting events, cheerleaders play a major role in entertaining the spectators. Their roles are substantial during breaks and prior to start of play. The world cup soccer is no exception. Usually the cheerleaders form a group and perform at the centre of the field. In addition to this group, some of them are placed outside the side line so they are closer to the spectators. The organizers would like to ensure that at least one cheerleader is located on each of the four sides. For this problem, we will model the playing ground as an M*N rectangular grid. The constraints for placing cheerleaders are described below:

    • There should be at least one cheerleader on each of the four sides. Note that, placing a cheerleader on a corner cell would cover two sides simultaneously.
    • There can be at most one cheerleader in a cell.
    • All the cheerleaders available must be assigned to a cell. That is, none of them can be left out.

     

    The organizers would like to know, how many ways they can place the cheerleaders while maintaining the above constraints. Two placements are different, if there is at least one cell which contains a cheerleader in one of the placement but not in the other. 

     

    Input

     

    The first line of input contains a positive integer T<=50, which denotes the number of test cases. T lines then follow each describing one test case. Each case consists of three nonnegative integers, 2<=M, N<=20 and K<=500. Here M is the number of rows and N is the number of columns in the grid. K denotes the number of cheerleaders that must be assigned to the cells in the grid.

     

     

    Output

    For each case of input, there will be one line of output. It will first contain the case number followed by the number of ways to place the cheerleaders as described earlier. Look at the sample output for exact formatting. Note that, the numbers can be arbitrarily large. Therefore you must output the answers modulo1000007.

    Sample Input

    Sample Output

    2

    2 2 1

    2 3 2

    Case 1: 0

    Case 2: 2

     

    k个石头放到  n*m 的矩阵 , 在4条边上一定要有石头有多少种方法 ? 

    用容斥来加加减减...

    集合A表示第一行没石头...集合B表示第二行没有石头.. D..C如痴类推。

    0 ~ 1<<16-1 表示出所有集合..

    当我们加上全集的时候,,,要剪一个除了A的集合,,,但是少剪了除了B的集合..

    若果剪了除了B的集合...我们多减了同时出去A.B情况的集合..这个时候要加回来..

    思想大概如此

    #include <bits/stdc++.h>
    using namespace std;
    unsigned long long C[501][501];
    const int mod = 1000007;
    
    void run()
    {
    
        unsigned long long ans = 0  , n  , m  , k ;
        cin >> n >> m >> k ;
        for( int s = 0 ; s < 16 ; ++s ){
            int b = 0 , r = n ,c = m ;
            if( s&1 ){ r-- ; b++ ;}
            if( s&2 ){ r-- ; b++ ;}
            if( s&4 ){ c-- ; b++ ;}
            if( s&8 ){ c-- ; b++ ;}
            if( b&1 ) ans = ( ans + mod - C[r*c][k] ) %mod ;
            else ans = ( ans + C[r*c][k] )%mod;
        }
        cout << ans << endl;
    }
    int main()
    {
        #ifdef LOCAL
            freopen("in.txt","r",stdin);
        #endif
        for( int i = 0 ; i <= 500 ; ++i ){
            C[i][0] = C[i][i] = 1 ;
            for( int j = 1 ; j < i ; ++j ){
                C[i][j] = ( C[i-1][j] + C[i-1][j-1] ) % mod ;
            }
        }
        int cas = 1 , _ ; cin >> _ ;
        while( _-- ) { cout << "Case "<< cas++ <<": "; run(); }
    }
    View Code
    only strive for your goal , can you make your dream come true ?
  • 相关阅读:
    《剑指Offer》算法题——“旋转数组”的最小数字
    驱动是如何运行的
    Logistic回归,梯度上升算法理论详解和实现
    Python 字符串前面加'r'
    Python中文编码问题(字符串前面加'u')
    最大长度回文子串(Manacher's algorithm)
    没有重复字符的子串的最大长度
    Python格式化输出
    python strip()函数和Split函数的用法总结
    Python中的sorted函数以及operator.itemgetter函数
  • 原文地址:https://www.cnblogs.com/hlmark/p/4060926.html
Copyright © 2020-2023  润新知