• 1048


    The Hardest Problem Ever
    
    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 15057    Accepted Submission(s): 6956
    
    
    Problem Description
    Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked. 
    You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite: 
    
    Cipher text
    A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
    
    Plain text
    V W X Y Z A B C D E F G H I J K L M N O P Q R S T U 
    
    Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.
     
    
    Input
    Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase. 
    
    A single data set has 3 components: 
    
    Start line - A single line, "START" 
    
    Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar 
    
    End line - A single line, "END" 
    
    Following the final data set will be a single line, "ENDOFINPUT".
     
    
    Output
    For each data set, there will be exactly one line of output. This is the original message by Caesar.
     
    
    Sample Input
    START
    NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX
    END
    START
    N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ
    END
    START
    IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ
    END
    ENDOFINPUT
     
    
    Sample Output
    IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES
    I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME
    DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE
    #include <iostream>
    #include <string>
    #include <string.h>
    #include <map>
    #include <cstdio>
    using namespace std;
    map<char,char> mp;
    void init(){
        mp['A']='V';mp['B']='W';mp['C']='X';mp['D']='Y';mp['E']='Z';mp['F']='A';mp['G']='B';mp['H']='C';mp['I']='D';mp['J']='E';
        mp['K']='F';mp['L']='G';mp['M']='H';mp['N']='I';mp['O']='J';mp['P']='K';mp['Q']='L';mp['R']='M';mp['S']='N';mp['T']='O';
        mp['U']='P';mp['V']='Q';mp['W']='R';mp['X']='S';mp['Y']='T';mp['Z']='U';//打表是个好方法
    }
    int main(){
        //freopen("1.txt","r",stdin);
        init();
        char ss[1005];
        string s1,s2,s3;
        while(gets(ss)){
          if(strcmp("START",ss)==0);//如果符合这个条件的话什么都不做
          else if(strcmp("END",ss)==0)puts("");//输出回车
          else if(strcmp("ENDOFINPUT",ss)==0)return 0;
          else{
            int len=strlen(ss);
            for(int i=0;i<len;++i){
              if(ss[i]>='A'&&ss[i]<='Z')
                  printf("%c",mp[ss[i]]);
              else
                  printf("%c",ss[i]);
            }
          }
        }
        return 0;
    }
  • 相关阅读:
    jar 包说明
    WebView 下载
    动画
    activity 做出 dialog 效果
    android 数据报表
    拖动 view
    开发收集
    tomcat 5 comcat 6 区别
    android 屏幕判断
    FPS游戏
  • 原文地址:https://www.cnblogs.com/hezixiansheng8/p/3715310.html
Copyright © 2020-2023  润新知