• HDU 1040


    As Easy As A+B
    
    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 35088    Accepted Submission(s): 15142
    
    
    Problem Description
    These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
    Give you some integers, your task is to sort these number ascending (升序).
    You should know how easy the problem is now!
    Good luck!
     
    
    Input
    Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line. 
    It is guarantied that all integers are in the range of 32-int.
     
    
    Output
    For each case, print the sorting result, and one line one case.
     
    
    Sample Input
    2
    3 2 1 3
    9 1 4 7 2 5 8 3 6 9
     
    
    Sample Output
    1 2 3
    1 2 3 4 5 6 7 8 9
     
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int cmp(int a,int b)
    {
        return a<b;
    }
    int main()
    {
        int t,i,n;
        int a[1005];
        cin>>t;
        while(t--)
        {
            cin>>n;
            for(i=0;i<n;i++)
            cin>>a[i];
            sort(a,a+n,cmp);
            for(i=0;i<n;i++)
            //cout<<a[i]<<" ";
            {
                if(i<n-1)
                cout<<a[i]<<" ";
                if(i==n-1)
                cout<<a[i];
            }
            cout<<endl;
        }
        return 0;
    }
  • 相关阅读:
    c语言 循环、数组、指针、冒泡排序、最大最小(上课)
    路由器远程配置实验
    一个排序小程序(上课)
    shells/clickhouse.sh
    shells/insertToTable.sh
    shells/flink.sh
    shells/hadoop.sh
    shells/flume.sh
    shells/hadoop
    练习:Flink ProcessWindowFunction、AggregateFunction、KeyedProcessFunction
  • 原文地址:https://www.cnblogs.com/hezixiansheng8/p/3714541.html
Copyright © 2020-2023  润新知