• POJ2236:Wireless Network(并查集)


    Wireless Network

    Time Limit: 10000MS   Memory Limit: 65536K
    Total Submissions: 39772   Accepted: 16479

    题目链接:http://poj.org/problem?id=2236

    Description:

    An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

    In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

    Input:

    The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
    1. "O p" (1 <= p <= N), which means repairing computer p.
    2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

    The input will not exceed 300000 lines.

    Output:

    For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

    Sample Input:

    4 1
    0 1
    0 2
    0 3
    0 4
    O 1
    O 2
    O 4
    S 1 4
    O 3
    S 1 4

    Sample Output:

    FAIL
    SUCCESS

    题意:

    给定n台电脑的位置以及一个距离d,有两个操作:修复以及检查是否连通。当电脑之间的距离小于d时则为连通,电脑也可以被作为其它电脑连通的中转站。

    题解:

    注意这题的time limit是10s...我一开始没注意这个想半天都没想出来。。。

    当发现这是10s后就好解决了,修复的时候将可以连通的放在一个集合里,然后询问的时候查询一下就好了。

    代码如下:

    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <iostream>
    using namespace std;
    
    const int N = 1005;
    int n,d;
    int f[N],vis[N];
    struct node{
        int x,y;
    }a[N];
    
    bool dist(node A,node B){
        int tmp1 = A.x-B.x,tmp2 = A.y-B.y;
        return tmp1*tmp1+tmp2*tmp2<=d*d;
    }
    
    int find(int x){return x==f[x] ? x : f[x]=find(f[x]);}
    
    int main(){
        scanf("%d%d",&n,&d);
        for(int i=1;i<=n;i++) scanf("%d%d",&a[i].x,&a[i].y);
        for(int i=1;i<=n+1;i++) f[i]=i;
        getchar();char c;
        while(scanf("%c",&c)!=EOF){
            if(c=='O'){
                int p;scanf("%d",&p);
                vis[p]=1;
                for(int i=1;i<=n;i++){
                    if(i==p) continue ;
                    if(vis[i] && dist(a[p],a[i])){
                        int fp=find(p),fi=find(i);
                        f[fp]=fi;
                    }
                }
            }else{
                int p1,p2;scanf("%d%d",&p1,&p2);
                int f1=find(p1),f2=find(p2);
                if(f1==f2){
                    puts("SUCCESS");
                }else puts("FAIL");
            }
            getchar();
        }
        return 0;
    }
  • 相关阅读:
    12个国外优秀.Net开源项目
    CYQ.Data 轻量数据层之路 V4.3 版本发布[增加对SQLite,MySQL数据库的支持]
    秋色园QBlog V2.5 后台管理系统源码发布下载
    秋色园QBlog技术原理解析:认识整站处理流程(二)
    CYQ.Data 数据框架 加快开源速度 发布V1.5.5版本源码
    秋色园[CYQ.Data]开源团队寻人
    秋色园QBlog技术原理解析:页面内容填充及多语言翻译流程演示示例(十)
    CYQ.Data 数据框架 性能评测
    框架设计:实现数据的按需更新与插入的改进
    秋色园QBlog技术原理解析:Module之基类生命周期页面加载(七)
  • 原文地址:https://www.cnblogs.com/heyuhhh/p/9986154.html
Copyright © 2020-2023  润新知