• POJ3169:Layout(差分约束)


    Layout

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 15705   Accepted: 7551

    题目链接:http://poj.org/problem?id=3169

    Description:

    Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

    Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

    Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

    Input:

    Line 1: Three space-separated integers: N, ML, and MD. 

    Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

    Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

    Output:

    Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

    Sample Input:

    4 2 1
    1 3 10
    2 4 20
    2 3 3

    Sample Output:

    27

    Hint:

    Explanation of the sample: 

    There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

    The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

    题意:

    有n只牛,之后给出m个关系x,y,z满足x号牛和y号牛相距不超过z,之后还会有k个关系x,y,z满足x,y相距至少为z。

    现在问1号牛和n号牛最大的距离可能是多少,如果此最大值不存在,输出-1;如若这个最大值有无穷多个,则输出-2。

    题解:

    就是个差分约束模板题,建个图跑一跑就好了。注意一下最后输出的顺序。

    代码如下:

    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <iostream>
    #include <queue>
    #define INF 9999999999999999
    using namespace std;
    typedef long long ll;
    const int N = 1005,M = 20005;
    ll d[N];
    int vis[N],head[N],c[N];
    int n,ml,md;
    struct Edge{
        int u,v,w,next;
    }e[M<<1];
    int tot;
    void adde(int u,int v,int w){
        e[tot].u=u;e[tot].v=v;e[tot].w=w;e[tot].next=head[u];head[u]=tot++;
    }
    ll spfa(int s){
        queue <int> q;
        for(int i=1;i<=n;i++) d[i]=INF;
        q.push(s);vis[s]=1;d[1]=0;c[1]=1;
        while(!q.empty()){
            int u=q.front();q.pop();vis[u]=0;
            if(c[u]>n) return -1;
            for(int i=head[u];i!=-1;i=e[i].next){
                int v=e[i].v;
                if(d[v]>=d[u]+e[i].w){
                    d[v]=d[u]+e[i].w;
                    if(!vis[v]){
                        vis[v]=1;
                        q.push(v);
                        c[v]++;
                    }
                }
            }
        }
        return d[n];
    }
    int main(){
        cin>>n>>ml>>md;
        memset(head,-1,sizeof(head));
        for(int i=1;i<=ml;i++){
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            adde(u,v,w);
        }
        for(int i=1;i<=md;i++){
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            adde(v,u,-w);
        }
        ll flag = spfa(1);
        if(flag==INF){
            cout<<-2;
            return 0;
        }
        else if(flag==-1) cout<<-1;
        else cout<<d[n];
        return 0;
    }
  • 相关阅读:
    JS连接数据库“实例”
    sql数据字典
    硬件防火墙的配置
    xxx
    rhs属性文件删除法
    思科pix防火墙配置实例大全
    SilverLight中的画刷小结
    数据库表间的连接总结
    导入Excel到Sql Server 2005 (转)
    关于Silverlight页面跳转的总结
  • 原文地址:https://www.cnblogs.com/heyuhhh/p/10332383.html
Copyright © 2020-2023  润新知