• [ZOJ 3471] Most Powerful


    Most Powerful

    Time Limit: 2 Seconds      Memory Limit: 65536 KB

    Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

    You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

    Input

    There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

    The last case is followed by a 0 in one line.

    There will be no more than 500 cases including no more than 50 large cases that N is 10.

    Output

    Output the maximal power these N atoms can produce in a line for each case.

    Sample Input

    2 0 4 1 0 3 0 20 1 12 0 1 1 10 0 0

    Sample Output

    4 22


    Author: GAO, Yuan Contest: ZOJ Monthly, February 2011

    简单状压DP、1A、见代码

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    using namespace std;
    #define INF 0x3f3f3f3f
    
    int n;
    int mpt[12][12];
    int dp[1<<12];          //dp[i]表示i状态(初始为0,爆炸后变为1)下的最大值
    
    void solve()
    {
        int i,j,k,MAX=1<<n;
        dp[0]=0;
        for(j=0;j<MAX;j++)
        {
            for(i=0;i<n;i++)
            {
                if(j&(1<<i)) continue;
                for(k=0;k<n;k++)
                {
                    if(i==k) continue;     //自身不能和自身反应
                    if(j&(1<<k)) continue;
                    dp[j|(1<<k)]=max(dp[j|(1<<k)],dp[j]+mpt[i][k]);
                }
            }
        }
        int ans=0;
        for(i=0;i<MAX;i++)
        {
            ans=max(ans,dp[i]);
        }
        cout<<ans<<endl;
    }
    int main ()
    {
        while(scanf("%d",&n),n)
        {
            memset(dp,0,sizeof(dp));
            for(int i=0;i<n;i++)
            {
                for(int j=0;j<n;j++)
                {
                    scanf("%d",&mpt[i][j]);
                }
            }
            solve();
        }
        return 0;
    }
    趁着还有梦想、将AC进行到底~~~by 452181625
  • 相关阅读:
    Delphi 多线程知识
    程序员最后归宿是什么?30或35想转行?
    做技术的最终出路!
    路在何方?分析程序员人生之路
    一个垂直滚动的插件
    jQuery 动画中 缓动效果的应用
    [转]jQuery性能优化指南 I
    jQuery 标记当前函数 开始写一个简单的插件
    我发现我写的这俩函数太好用了~~
    jQuery浏览器版本判断
  • 原文地址:https://www.cnblogs.com/hate13/p/4104754.html
Copyright © 2020-2023  润新知