Problem Description
In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.
Input
The
input contains four parts: 1) a dictionary, which consists of at least
one and at most 100 words, one per line; 2) a line containing XXXXXX,
which signals the end of the dictionary; 3) one or more scrambled
'words' that you must unscramble, each on a line by itself; and 4)
another line containing XXXXXX, which signals the end of the file. All
words, including both dictionary words and scrambled words, consist only
of lowercase English letters and will be at least one and at most six
characters long. (Note that the sentinel XXXXXX contains uppercase X's.)
The dictionary is not necessarily in sorted order, but each word in the
dictionary is unique.
Output
For
each scrambled word in the input, output an alphabetical list of all
dictionary words that can be formed by rearranging the letters in the
scrambled word. Each word in this list must appear on a line by itself.
If the list is empty (because no dictionary words can be formed), output
the line "NOT A VALID WORD" instead. In either case, output a line
containing six asterisks to signal the end of the list.
Sample Input
tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX
Sample Output
score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******
题意:第一个XXXXXX前是一个字典,对于第二个XXXXXX前的单词输出字典,须排序;
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char word[105][10];
int cmp(const void *p1,const void *p2){
return (strcmp((char *)p1,(char *)p2));
}
int Judge(char m[],char n[]){int t1,t2;
t1=strlen(m);t2=strlen(n);
sort(m,m+t1);sort(n,n+t2);
if(strcmp(n,m)==0)return 1;
else return 0;
}
int main(){int i,temp;char s[10],t[10],p[10];
for(i=0;scanf("%s",word[i]),strcmp(word[i],"XXXXXX");++i);
/*for(int z=0;z<=i;++z){
for(int j=z;j<=i;j++){
if(strcmp(word[z],word[j])>0)strcpy(p,word[z]),strcpy(word[z],word[j]),strcpy(word[j],p);
}
}*///冒泡排序;
qsort(word,i,sizeof(word[0]),cmp);//qsort poj上一直wa,杭电过了;运行时间和内存都特别大。。。。。
while(scanf("%s",s),strcmp(s,"XXXXXX")){temp=0;
for(int j=0;j<=i;j++){strcpy(t,word[j]);
if(Judge(s,t))temp=1,printf("%s ",word[j]);
}
if(!temp)printf("NOT A VALID WORD ");
printf("****** ");
}
return 0;
}
#include<string.h>
#include<algorithm>
using namespace std;
char word[105][10];
int cmp(const void *p1,const void *p2){
return (strcmp((char *)p1,(char *)p2));
}
int Judge(char m[],char n[]){int t1,t2;
t1=strlen(m);t2=strlen(n);
sort(m,m+t1);sort(n,n+t2);
if(strcmp(n,m)==0)return 1;
else return 0;
}
int main(){int i,temp;char s[10],t[10],p[10];
for(i=0;scanf("%s",word[i]),strcmp(word[i],"XXXXXX");++i);
/*for(int z=0;z<=i;++z){
for(int j=z;j<=i;j++){
if(strcmp(word[z],word[j])>0)strcpy(p,word[z]),strcpy(word[z],word[j]),strcpy(word[j],p);
}
}*///冒泡排序;
qsort(word,i,sizeof(word[0]),cmp);//qsort poj上一直wa,杭电过了;运行时间和内存都特别大。。。。。
while(scanf("%s",s),strcmp(s,"XXXXXX")){temp=0;
for(int j=0;j<=i;j++){strcpy(t,word[j]);
if(Judge(s,t))temp=1,printf("%s ",word[j]);
}
if(!temp)printf("NOT A VALID WORD ");
printf("****** ");
}
return 0;
}
两样对比,可能自己对qsort理解有问题吧。。。。