• 1087 All Roads Lead to Rome


    Indeed there are many different tourist routes from our city to Rome. You are supposed to find your clients the route with the least cost while gaining the most happiness.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 2 positive integers N (2), the number of cities, and K, the total number of routes between pairs of cities; followed by the name of the starting city. The next N−1 lines each gives the name of a city and an integer that represents the happiness one can gain from that city, except the starting city. Then K lines follow, each describes a route between two cities in the format City1 City2 Cost. Here the name of a city is a string of 3 capital English letters, and the destination is always ROM which represents Rome.

    Output Specification:

    For each test case, we are supposed to find the route with the least cost. If such a route is not unique, the one with the maximum happiness will be recommanded. If such a route is still not unique, then we output the one with the maximum average happiness -- it is guaranteed by the judge that such a solution exists and is unique.

    Hence in the first line of output, you must print 4 numbers: the number of different routes with the least cost, the cost, the happiness, and the average happiness (take the integer part only) of the recommanded route. Then in the next line, you are supposed to print the route in the format City1->City2->...->ROM.

    Sample Input:

    6 7 HZH
    ROM 100
    PKN 40
    GDN 55
    PRS 95
    BLN 80
    ROM GDN 1
    BLN ROM 1
    HZH PKN 1
    PRS ROM 2
    BLN HZH 2
    PKN GDN 1
    HZH PRS 1
    
     

    Sample Output:

    3 3 195 97
    HZH->PRS->ROM

    题意:

    题目大体上是一个求最短路的问题,只不过又在此基础上增加了一些其他的内容,比如说:找出最短路的条数,以及路途过程中happinese的最大值和average happinese的最大值问题。

    思路:

    最短路径涉及到图论,所以就要表示出图,这里我用的是连接矩阵来表示图,所以先用map将城市的名字改成数字,最后输出的时候再改回来。然后就是用Dijkstra来求最短路了。

    Code:

    #include<iostream>
    #include<map>
    #include<string>
    #include<vector>
    #include<stack>
    
    using namespace std;
    const int Inf = 0x7fffffff;
    
    int findMinDist(vector<int> &dist, vector<bool> &collected) {
        int ret = Inf, j = -1;
        int len = dist.size();
        for (int i = 1; i < len; ++i) {
            if (!collected[i] && ret > dist[i]) {
                ret = dist[i];
                j = i;
            }
        }
        return j;
    }
    
    int main() {
        int n, k;
        string start;
    
        cin >> n >> k >> start;
    
        map<string, int> EnToNum;
        map<int, string> NumToEn;
        EnToNum[start] = 0;
        NumToEn[0] = start;
        vector<int> happiness(n);
        string name;
        int value;
        for (int i = 1; i < n; ++i) {
            cin >> name >> value;
            EnToNum[name] = i;
            NumToEn[i] = name;
            happiness[i] = value;
        }
    
        vector<vector<int> > martix(n, vector<int>(n, -1));
        vector<bool> collected(n, false);
        vector<int> path(n, -1);
        string name1, name2;
        int num1, num2, cost;
        for (int i = 0; i < k; ++i) {
            cin >> name1 >> name2 >> cost;
            num1 = EnToNum[name1];
            num2 = EnToNum[name2];
            martix[num1][num2] = cost;
            martix[num2][num1] = cost;
        }
    
        vector<int> dist(n, Inf);
        dist[0] = 0;
        collected[0] = true;
        for (int i = 1; i < n; ++i) {
            if (martix[0][i] > 0) {
                dist[i] = martix[0][i];
                path[i] = 0;
            }
        }
    
        int end = EnToNum["ROM"];
        vector<pair<int, int> > backtrack;
        // Dijkstra算法
        while (1) {
            int minVertex = findMinDist(dist, collected);
            if (minVertex == -1) break;
            collected[minVertex] = true;
            for (int i = 0; i < n; ++i) {
                if (martix[minVertex][i] > 0 && !collected[i]) {
                    if (dist[minVertex] + martix[minVertex][i] <= dist[i]) {
                        dist[i] = dist[minVertex] + martix[minVertex][i];
                        path[i] = minVertex;
                        if (i == end) {
                            backtrack.push_back({dist[i], minVertex});
                        }
                    }
                }
            }
        }
    
        int count = 0;
        vector<int> Vbacktrack;
        for (int i = 0; i < backtrack.size(); ++i) {
            if (backtrack[i].first == dist[end]) {
                count++;
                Vbacktrack.push_back(backtrack[i].second);
            }
        }
    
        int maxHappinese = -1, aveHappinese = -1;
        int maxHappVertex;
        for (int i = 0; i < Vbacktrack.size(); ++i) {
            int begin = Vbacktrack[i], temp = happiness[end], numOfVertex = 1;
            while (path[begin] != -1) {
                temp += happiness[begin];
                numOfVertex++;
                begin = path[begin];
            }
            if (temp > maxHappinese) {
                maxHappinese = temp;
                aveHappinese = temp / numOfVertex;
                maxHappVertex = Vbacktrack[i];
            } else if (temp == maxHappinese && aveHappinese < temp/numOfVertex) {
                aveHappinese = temp / numOfVertex;
                maxHappVertex = Vbacktrack[i];
            }
        }
    
        cout << dist[end] << " " << count << " " << maxHappinese << " " << aveHappinese << endl;
    
        stack<int> pathToRom;
        pathToRom.push(end);
        while (path[maxHappVertex] != -1) {
            pathToRom.push(maxHappVertex);
            maxHappVertex = path[maxHappVertex];
        }
        cout << start;
        while (!pathToRom.empty()) {
            cout << "->" << NumToEn[pathToRom.top()];
            pathToRom.pop();
        }
        cout << endl;
    
        return 0;
    }
    

      

    搞了半天就通过了一组数据。

    永远渴望,大智若愚(stay hungry, stay foolish)
  • 相关阅读:
    学习笔记—查找
    水晶报表图表制作问题
    Chrome对最小字体的限制
    Devexpress的ASPxDateEdit控件设置其‘today’ 为客户端当前日期
    水晶报表多表数据源
    System.Web.HttpValueCollection.ThrowIfMaxHttpCollectionKeysExceeded
    利用水晶报表制作甘特图
    水晶报表打印时最后多打印一空白页
    day3学习
    Python高级自动化培训day1
  • 原文地址:https://www.cnblogs.com/h-hkai/p/12633878.html
Copyright © 2020-2023  润新知