• 1004 Counting Leaves


    A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing 0, the number of nodes in a tree, and M (<), the number of non-leaf nodes. Then M lines follow, each in the format:

    ID K ID[1] ID[2] ... ID[K]
    
     

    where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

    The input ends with N being 0. That case must NOT be processed.

    Output Specification:

    For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

    The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

    Sample Input:

    2 1
    01 1 02
    
     

    Sample Output:

    0 1

    题意:

    给一棵树,寻找每一层的叶子节点数。输入的第一行的两个数是结点的总数和非叶子结点的个数。

    Code:

    #include<iostream>
    #include<vector>
    #include<algorithm>
    #include<cstdio>
    
    using namespace std;
    
    vector<int> v[100];
    int book[100], maxdepth = -1;
    
    void dfs(int index, int depth) {
        if (v[index].size() == 0) {             //是不是叶子节点
            book[depth]++;
            maxdepth = max(maxdepth, depth);
            return ;
        }
        for (int i = 0; i < v[index].size(); ++i)   // 遍历该节点的子节点
            dfs(v[index][i], depth + 1);        
    }
    
    int main() {
    
        int n, m, k, node, c;
        scanf("%d %d", &n, &m);
        for (int i = 0; i < m; ++i) {
            scanf("%d %d", &node, &k);
            for (int j = 0; j < k; ++j) {
                scanf("%d", &c);
                v[node].push_back(c);
            }
        }
    
        dfs(1, 0);
    
        printf("%d", book[0]);
        for(int i = 1; i <= maxdepth; ++i)
            printf(" %d", book[i]);
    
        return 0;
    }

    参考:

    https://www.liuchuo.net/archives/2229

    永远渴望,大智若愚(stay hungry, stay foolish)
  • 相关阅读:
    Laravel自定义分页样式
    mysql中 key 、primary key 、unique key 和 index 有什么不同
    PHP RSA公私钥的理解和示例说明
    PHP操作Excel – PHPExcel 基本用法
    Yii 1.1 常规框架部署和配置
    阿里云服务器 Ubuntu 安装 LNMP
    全国地区sql表
    十道海量数据处理面试题与十个方法大总结
    Hibernate中对象的三种状态以及Session类中saveOrUpdate方法与merge方法的区别
    乐观锁与悲观锁——解决并发问题
  • 原文地址:https://www.cnblogs.com/h-hkai/p/12560987.html
Copyright © 2020-2023  润新知