• Bad version number in .class file


    TY项目是用JDK1.6做的,早先在电脑上装了一个1.5的,这回就不能用了。为了能用,我就又装了一个1.6的,修改了环境变量之后,以为一切OK。开始测试,首先在Myeclipse中打开我用1.5编的一个小类,重新编译了一下,就是回个车什么的,总之就是重新保存一下就OK。运行的时候,出现错误了: 

    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    java.lang.UnsupportedClassVersionError: Bad version number in .class file
     at java.lang.ClassLoader.defineClass1(Native Method)
     at java.lang.ClassLoader.defineClass(Unknown Source)
     at java.security.SecureClassLoader.defineClass(Unknown Source)
     at java.net.URLClassLoader.defineClass(Unknown Source)
     at java.net.URLClassLoader.access$100(Unknown Source)
     at java.net.URLClassLoader$1.run(Unknown Source)
     at java.security.AccessController.doPrivileged(Native Method)
     at java.net.URLClassLoader.findClass(Unknown Source)
     at java.lang.ClassLoader.loadClass(Unknown Source)
     at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
     at java.lang.ClassLoader.loadClass(Unknown Source)
     at java.lang.ClassLoader.loadClassInternal(Unknown Source) 
    


    很明显,是版本有问题,导致编译出现错误。其实以前碰到过这个问题,忘了怎么解决了(历史有一次证明我是个健忘的人,~~!!!)。最终我找到解决方法了: 

    首先,在菜单栏 选择 window?---Preference,如附件图1所示。 

    第二,选择Java树形栏,选择Compiler,如附件图2,可以看到compiler的jdk版本。 

    第三,选择Java树形栏,选择Installed JRES,可以看到你用到的JRE的版本,如附件图3。 

    第四,通过对比上述两个地方,将他们协调为一致(你需要的版本)或者将jdk的版本设为低于jre版本即可。 

  • 相关阅读:
    Java8 新的日期和时间API(笔记)
    java对象的强引用,软引用,弱引用和虚引用
    对性能有何帮助(读书笔记)
    ThreadLocal的实现原理(读书笔记)
    ThreadLocal的简单使用(读书笔记)
    编程、滑板与做饭
    在三四线城市谈软件业务,及其他
    EOS开发中内存RAM如何买卖
    用Visual Studio和c#开发以太坊dapp
    使用PHP和树莓派开发一个比特币和以太坊交易机器人
  • 原文地址:https://www.cnblogs.com/gw811/p/4253068.html
Copyright © 2020-2023  润新知