• POJ 1504 Adding Reversed Numbers


    /*Sample Input

     

     3

     24 1

     4358 754

     305 

     

     Sample Output

     

     34

     1998

     */

    值得总结的几点就是:

    1、atoi函数将字符串转化为整型数字(类似于强制转换)

    2、sprintf函数的用法,比如sprintf(res,"%d",i+j);

    3、这种将字符串逆置的方法应该是最简洁的

    #include<iostream>

    #include <stdio.h>

    #include <stdlib.h>

    #include <string.h>

    using namespace std;

    void toreverse(char ch[])

    {

        int i;

        int n=(int)strlen(ch);

        char temp;

        for(i=0;i<n/2;i++)

        {

            temp=ch[i];

            ch[i]=ch[n-1-i];

            ch[n-1-i]=temp;

        }

    }

     

    int main()

    {

        int N,i,j;

        char res[10],a[10],b[10];

        cin>>N;

        while(N--)

        {

            cin>>a>>b;

            toreverse(a);

            toreverse(b);

            i = atoi(a);//atoi函数将字符串转化为数字(int

             j = atoi(b);

            sprintf(res,"%d",i+j);

            toreverse(res);

            printf("%d ",atoi((char *)res));

        }

        return 0;

    }

          

     

  • 相关阅读:
    Javascript中得到中英文混合字符串的长度
    通往幸福之路之贷款篇
    骠叔
    神医
    买酱油与软件工程阶段划分
    XSLT中用normalizespace函数来清除元素的前后空格
    论屎
    Web程序中利用web.config解决无法输出excel页面的问题
    项目打单时该写什么文挡
    天桥底下是我家
  • 原文地址:https://www.cnblogs.com/guohaoyu110/p/6323775.html
Copyright © 2020-2023  润新知