• 7-4 jmu-Java&Python-统计文字中的单词数量并按出现次数排序 (25分)


    现在需要统计若干段文字(英文)中的单词数量,并且还需统计每个单词出现的次数。

    注1:单词之间以空格(1个或多个空格)为间隔。
    注2:忽略空行或者空格行。

    基本版:
    统计时,区分字母大小写,且不删除指定标点符号。

    进阶版:

    统计前,需要从文字中删除指定标点符号! . , : * ?。 注意:所谓的删除,就是用1个空格替换掉相应字符。
    统计单词时需要忽略单词的大小写。
    输入说明
    若干行英文,最后以!!!!!为结束。

    输出说明

    单词数量
    出现次数排名前10的单词(次数按照降序排序,如果次数相同,则按照键值的字母升序排序)及出现次数。

    输入样例1

    failure is probably the fortification in your pole

    it is like a peek your wallet as the thief when you
    are thinking how to spend several hard-won lepta

    when you are wondering whether new money it has laid
    background because of you then at the heart of the

    most lax alert and most low awareness and left it

    godsend failed
    !!!!!

    输出样例1

    46
    the=4
    it=3
    you=3
    and=2
    are=2
    is=2
    most=2
    of=2
    when=2
    your=2

    输入样例2

    Failure is probably The fortification in your pole!

    It is like a peek your wallet as the thief when You
    are thinking how to. spend several hard-won lepta.

    when yoU are? wondering whether new money it has laid
    background Because of: yOu?, then at the heart of the
    Tom say: Who is the best? No one dare to say yes.
    most lax alert and! most low awareness and* left it

    godsend failed
    !!!!!

    输出样例2

    54
    the=5
    is=3
    it=3
    you=3
    and=2
    are=2
    most=2
    of=2
    say=2
    to=2

    解题过程:

    python3中移除了sort中的cmp,利用cmp_to_key及自订函数进行排序

    python代码:

    from functools import cmp_to_key
    
    def cmpkey2(x,y):
        if x[1]>y[1]:
            return  1
        elif x[1]<y[1]:
            return  -1
        elif x[0]>y[0]:
            return  -1
        elif x[0]<y[0]:
            return  1
        return 0
    
    text = ""
    while True:
        s = input()
        if s == '!!!!!':
            break
        text += ' '
        text += s
    text = text.lower()
    for ch in '!.,:*?':
        text=text.replace(ch, ' ')
    cnt = {}
    for word in text.split():
        cnt[word] = cnt.get(word, 0) + 1
    items = list(cnt.items())
    items.sort(key=cmp_to_key(cmpkey2),reverse=True)
    print(len(items))
    for i in range(10):
        if i>=len(items):
            break
        key, val = items[i]
        print("{}={}".format(key, val))
    
    
  • 相关阅读:
    Error 1313: RETURN is only allowed in a FUNCTION SQL Statement
    Error Code: 1318. Incorrect number of arguments for PROCEDURE student.new_procedure; expected 0, got
    Error Code: 1305. FUNCTION student.rand_string does not exist
    Error Code: 1630. FUNCTION rand.string does not exist
    初入职场少年时,谁人不犯错?——北漂18年(6)
    错误代码: 1064
    第30章 表维护
    消息系统kafka及其变种Jafka、Metamorphosis (MetaQ)
    KAFKA分布式消息系统
    FineReport的JS编辑框和URL地址栏语法简介
  • 原文地址:https://www.cnblogs.com/graytido/p/12618875.html
Copyright © 2020-2023  润新知