Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9893 Accepted Submission(s): 6996
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4 10 20
Sample Output
5 42 627
Author
Ignatius.L
母函数.....对于任意一个数你 (1+x+x^2+x^3+x^4+x^5+x^6+x^7...+x^n)*(1+x^2+x^4+x^6+x^8+x^10+.....)*(1+x^3+.....);
1 #include<iostream> 2 #include<vector> 3 using namespace std; 4 int main() 5 { 6 int n,i,j,k; 7 while(cin>>n) 8 { 9 vector<int>c1(n+1,1); 10 vector<int>c2(n+1,0); 11 for(i=2;i<=n;i++) 12 { 13 for(j=0;j<=n;j++) 14 { 15 for(k=0;k+j<=n;k+=i) 16 { 17 c2[j+k]+=c1[j]; 18 } 19 } 20 for(j=1;j<=n;j++) 21 { 22 c1[j]=c2[j]; 23 c2[j]=0; 24 } 25 } 26 cout<<c1[n]<<endl; 27 } 28 return 0; 29 }