• Fibonacci Again


    Fibonacci Again

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 8   Accepted Submission(s) : 3
    Problem Description
    There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
     
    Input
    Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
     
    Output
    Print the word "yes" if 3 divide evenly into F(n).

    Print the word "no" if not.
     
    Sample Input
    0
    1
    2
    3
    4
    5
     
    Sample Output
    no
    no
    yes
    no
    no
    no
     
     
    code:

    #include<stdio.h>
    int f[1000001];
    int main()
    {
         int n,i;
         while(scanf("%d",&n)!=EOF)
        {
                 f[0]=7,f[1]=11;
               if(n==0||n==1)
                    printf("no ");
              else
             {
                    for(i=2;i<=1000000;i++)
                         f[i]=(f[i-1]%3+f[i-2]%3)%3;
                   if(f[n]==0)
                         printf("yes ");
                   else
                         printf("no ");
            }
         }
        return 0;
    }

    余数里面的一条公式:(a+b)%3 = (a%3+b%3)%3

    Wrong Answer:

    #include<stdio.h>
    int f[1000000];
    int main()
    {
            int n,i;
           while(scanf("%d",&n)!=EOF)
           {
                 if(n==0||n==1)
                    printf("no ");
                 else
                 {
                      f[0]=7,f[1]=11;
                     for(i=2;i<=n;i++)
                          f[i]=f[i-1]+f[i-2];
                     if(f[n]%3==0)
                         printf("yes ");
                     else
                        printf("no ");
                 }
           }
        return 0;
    }

     
     
     
     
     
     
  • 相关阅读:
    Spring MVC之视图呈现
    Spring MVC之HandlerMap 初始化
    Spring MVC之DispatcherServlet请求处理
    合成模式
    缺省适配器
    适配器模式
    原始模型
    克隆 和 比较
    建造模式
    线段树
  • 原文地址:https://www.cnblogs.com/gongpulin/p/3921906.html
Copyright © 2020-2023  润新知