• acm寒假特辑1月22日HDU


    G - 7 HDU - 1241 (dfs)

    G原题地址

    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

    Input
    The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either “*” representing the absence of oil, or ‘@’, representing an oil pocket.

    Output
    For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

    Sample Input
    1 1
    *
    3 5
    *@*@*
    **@**
    *@*@*
    1 8
    @@****@*
    5 5 
    ****@
    *@@*@
    *@**@
    @@@*@
    @@**@
    0 0 
    Sample Output
    0
    1
    2
    2
    

    题目大意“@”为油田,“*”无油,上下左右,斜对角连在一起的就算是一整块油田,题目问有多少块(整块)油田。

    tips:第一次wa了,是因为sum没放入循环之中,每跑一次都要重置为0才行。

    想法:可以使用dfs,建立图,每个点来一次dfs,所经历的地方进行标记,防止二次探索同一块大油田。

    #include<iostream>
    using namespace std;
    char map[105][105];
    int m=0, n=0, sum = 0;
    void dfs(int i, int j)
    {
    	if (map[i][j] != '@' || i<0 || j<0 || i >= m || j >= n) return;//确保不出界
    	else
    	{
    		map[i][j] = '!';
    		dfs(i - 1, j);//横
    		dfs(i + 1, j);
    		dfs(i, j - 1);//竖
    		dfs(i, j + 1);
    		dfs(i - 1, j - 1);//其余对角
    		dfs(i - 1, j + 1);
    		dfs(i + 1, j - 1);
    		dfs(i + 1, j + 1);
    	}
    }
    int main()
    {
    	
    	while (cin >> m >> n)
    	{
    		if (m == 0 || n == 0)
    			break;
    		sum = 0;
    		for (int i = 0; i < m; i++)
    		{
    			for (int j = 0; j < n; j++)
    				cin >> map[i][j];
    		}
    		for (int i = 0; i < m; i++)
    		{
    			for (int j = 0; j < n; j++)
    			{
    				if (map[i][j] == '@')//找到开头
    				{
    					dfs(i, j);
    					sum++;
    				}
    			}
    		}
    		cout << sum << endl;
    	}
        return 0;
    }
    
  • 相关阅读:
    python 连接ubuntu xampp mysql
    [解决] win7能上网,ubuntu14.04不行
    ubuntu14.04 安装 pyv8
    QT_QMAKE_EXECUTABLE reported QT_INSTALL_LIBS as /usr/lib/i386-linux-gnu but ...
    网站运营思想
    织梦直接往数据库写入数据
    [xunsearch] 在thinkphp中使用xunsearch
    [xampp] phpmyadmin 设置登录密码
    [centos6.5] 把xampp的htdocs改为其他目录
    [ubuntu] service apache2 restart [fail]
  • 原文地址:https://www.cnblogs.com/gidear/p/10433308.html
Copyright © 2020-2023  润新知