• HDU1078 FatMouse and Cheese 【内存搜索】


    FatMouse and Cheese

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 4966    Accepted Submission(s): 2035


    Problem Description
    FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

    FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

    Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
     

    Input
    There are several test cases. Each test case consists of

    a line containing two integers between 1 and 100: n and k
    n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
    The input ends with a pair of -1's.
     

    Output
    For each test case output in a line the single integer giving the number of blocks of cheese collected.
     

    Sample Input
    3 1 1 2 5 10 11 6 12 12 7 -1 -1
     

    Sample Output
    37
     

    Source
     

    题意:给定一张N*N的图。每一个格子上有一些豆子,初始位置是(0,0)。每次仅仅能向一个方向走最多m步,然后停下吃掉这个格子上的豆子。但有个限制是当前格子上的豆子必须比之前呆的一个格子里的豆子多。问最多能吃多少豆子。

    题解:深搜,dp[i][j]表示从(i,j)点出发最多能吃到的豆子。


    #include <stdio.h>
    #include <string.h>
    
    #define maxn 105
    
    int G[maxn][maxn], n, m;
    int dp[maxn][maxn];
    const int mov[][2] = {1, 0, -1, 0, 0, 1, 0, -1};
    
    void getMap() {
    	int i, j;
    	for(i = 0; i < n; ++i)
    		for(j = 0; j < n; ++j)
    			scanf("%d", &G[i][j]);
    }
    
    int max(int a, int b) {
    	return a > b ?

    a : b; } bool check(int x, int y) { if(x < 0 || x >= n || y < 0 || y >= n) return 0; return 1; } int DFS(int xx, int yy) { int i, j, x, y, maxv = 0; if(dp[xx][yy]) return dp[xx][yy]; for(i = 1; i <= m; ++i) { for(j = 0; j < 4; ++j) { x = xx + mov[j][0] * i; y = yy + mov[j][1] * i; if(check(x, y) && G[x][y] > G[xx][yy]) maxv = max(maxv, DFS(x, y)); } } return dp[xx][yy] = maxv + G[xx][yy]; } void solve() { int i, j; memset(dp, 0, sizeof(dp)); printf("%d ", DFS(0, 0)); } int main() { // freopen("stdin.txt", "r", stdin); while(scanf("%d%d", &n, &m), n > 0) { getMap(); solve(); } return 0; }



    版权声明:本文博主原创文章。博客,未经同意不得转载。

  • 相关阅读:
    linux常用命令
    UnicodeDecodeError: 'gbk' codec can't decode byte 0xab in position 2411: illegal multibyte sequence错误解决方案
    python中的yield通俗理解
    搭建hadoop+spark+hive环境(centos极速安装和配置hive)
    搭建hadoop+spark+hive环境(centos极速安装和配置spark)
    搭建hadoop+spark+hive环境(centos全远程hadoop极速安装及配置)
    pycharm使用conda环境,部分包没有代码提示或包名没有显示
    anaconda下安装的TensorFlow没有代码补全解决方案
    faceswap安装,配置,使用记录(RTX2060s+CUDA10.1+cudnn7.6.2+Anaconda3.5.2+tensorflow-gpu)(一)
    Leetcode 872. 叶子相似的树
  • 原文地址:https://www.cnblogs.com/gcczhongduan/p/4853733.html
Copyright © 2020-2023  润新知