• Monthly Expense


    Problem Description

    Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

    FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

    FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

     

    Input
    Line 1: Two space-separated integers: N and M 
    Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
     

    Output
    Line 1: The smallest possible monthly limit Farmer John can afford to live with.
     

    Sample Input
    7 5 100 400 300 100 500 101 400
     

    Sample Output
    500
     

    #include<iostream>
    #include<cstdio>
    using namespace std;
    int n,m;
    int a[100010];
    int fun(int s)   //fun函数是推断当前的mid值能把n分成几组
    {                //通过比較q与m的大小,对mid的值进行优化
        int sum=0,q=1;
        for(int i=1;i<=n;i++)//从第一天開始向下遍历每天的花费
        {
            if(sum+a[i]<=s)//前第I天和<=mid时,把他们归为这一组
                sum+=a[i];
            else//否则。第i天做为下一组的第一天
            {
                sum=a[i];
                q++;//组数加一
            }
        }
        if(q>m)//组数大于m,代表mid数值小了,
            return 0;
        return 1;//否则大了
    }
    int main()
    {
        while(~scanf("%d%d",&n,&m)){
            int l,r=0,mid,min=0,sum=0;
            for(int i=1;i<=n;i++)
            {
                scanf("%d",&a[i]);
                sum+=a[i];
                if(a[i]>r)r=a[i];
            }
            l=sum;
            int ans=0;
            mid=(l+r)/2;
            while(r<l)
            {
                if(!fun(mid))//假设mid偏小
                {
    
                   r=mid+1;//下界上升
                }
                else//否则
                {
                    l=mid-1;//上限下降
                }
                 mid=(r+l)/2;
            }
            cout<<mid<<endl;
        }
        return 0;
    }
    


  • 相关阅读:
    hdu_5961_传递(bitset)
    hdu_5963_朋友(找规律)
    hdu_5968_异或密码(预处理+二分)
    hdu_5969_最大的位或(贪心)
    hdu_5965_扫雷(递推)
    hdu_5950_Recursive sequence(矩阵快速幂)
    hdu_5286_wyh2000 and sequence(分块)
    [BZOJ1951][SDOI2005]古代猪文(数论好题)
    [BZOJ2659][WC2012]算不出的算式(几何)
    [BZOJ 2656][ZJOI2012]数列(递归+高精度)
  • 原文地址:https://www.cnblogs.com/gcczhongduan/p/4563217.html
Copyright © 2020-2023  润新知