• 1078. Hashing (25)【Hash + 探測】——PAT (Advanced Level) Practise


    题目信息

    1078. Hashing (25)

    时间限制100 ms
    内存限制65536 kB
    代码长度限制16000 B
    The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be “H(key) = key % TSize” where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

    Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=10^4) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

    Sample Input:
    4 4
    10 6 4 15
    Sample Output:
    0 1 4 -

    解题思路

    题目默认你已掌握平方二次探測,有多坑逼。,,,

    AC代码

    #include <cstdio>
    #include <cmath>
    bool a[20005];
    bool prime(int a){
        if (1 == a) return false;
        if (2 == a || 3 == a) return true;
        int t = (int)sqrt(a);
        for (int i = 2; i <= t; ++i){
            if (a%i == 0){
                return false;
            }
        }
        return true;
    }
    int main()
    {
        int ms, n, ts, t, i, j;
        scanf("%d%d", &ms, &n);
        ts = ms;
        while (!prime(ts)){
            ++ts;
        }
        for (i = 0; i < n; ++i){
            scanf("%d", &t);
            for (j = 0; j < n; ++j){
                if (!a[(t + j*j) % ts]){
                    a[(t + j*j) % ts] = true;
                    printf("%s%d", i ?

    " ":"", (t + j*j) % ts); break; } } int loc = t % ts; if (j == n){ printf("%s-", i ? " ":""); } } return 0; }

  • 相关阅读:
    Android Studio 快捷键
    Mac 下面,添加android adb命令(一般环境变量的添加方法)
    快速掌握 Android Studio 中 Gradle 的使用方法
    JAVA 十六进制与字符串的转换
    总结自己的Git常用命令
    Android性能优化典范---转
    【.NET Core微服务实战-统一身份认证】开篇及目录索引
    调用API修改Ocelot的配置文件
    VUE组件汇总
    Vue + GraphQL初试
  • 原文地址:https://www.cnblogs.com/gavanwanggw/p/7382104.html
Copyright © 2020-2023  润新知