• POJ 1159 Palindrome


    Palindrome
    Time Limit: 3000MS   Memory Limit: 65536K
    Total Submissions: 51518   Accepted: 17733

    Description

    A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

    As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

    Input

    Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

    Output

    Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

    Sample Input

    5
    Ab3bd

    Sample Output

    2


    简单的 区间动规,主要是easyMLE。


    AC代码例如以下:

    #include<iostream>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    char a[5005];
    short dp[5005][5005];//用short就能够不MLE了
    int min(int a,int b)
    {
        return a<b?a:b;
    }
    
    int main()
    {
        int n;
        int ans;
        int i,j;
        while(cin>>n)
        {
            memset(dp,0,sizeof dp);
            cin>>a+1;
            //cout<<a+1;
            for(i=1;i<=n;i++)
            {
                dp[i][i]=0;//i==j时不用补字母
            }
            int len;
            for(len=2;len<=n;len++)
            {
                for(i=1;i<=n-len+1;i++)
                {
                    j=i+len-1;
                    if(a[i]==a[j])//此时[i,j]须要补字母数等于[i+1,j-1]中所需补的字母
                        dp[i][j]=dp[i+1][j-1];
                    else
                    {
                        dp[i][j]=min(dp[i][j-1],dp[i+1][j])+1;//此时须要找两个缩小区间的最小值
                    }
    
                }
            }
            cout<<dp[1][n]<<endl;
        }
        return 0;
    }
    


  • 相关阅读:
    oracle Constraint[相似 constraint使用方法总结 I]
    四个好看的CSS样式表格
    自己动手写操作系统--个人实践
    开机黑屏 仅仅显示鼠标 电脑黑屏 仅仅有鼠标 移动 [已成功解决]
    海量数据存储
    windows的定时任务设置
    人脸识别算法初次了解
    Java替代C语言的可能性
    二叉排序树
    海量数据处理面试题集锦
  • 原文地址:https://www.cnblogs.com/gavanwanggw/p/7009029.html
Copyright © 2020-2023  润新知