• POJ 3041 Asteroids


    Asteroids
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 14371   Accepted: 7822

    Description

    Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

    Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

    Input

    * Line 1: Two integers N and K, separated by a single space. 
    * Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

    Output

    * Line 1: The integer representing the minimum number of times Bessie must shoot.

    Sample Input

    3 4
    1 1
    1 3
    2 2
    3 2
    

    Sample Output

    2
    

    Hint

    INPUT DETAILS: 
    The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
    X.X 
    .X. 
    .X.
     

    OUTPUT DETAILS: 
    Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

    匈牙利算法!

    !!

    主要是要懂得将问题转化。

    将行列转化为二分两个集合。然后坐标点(i,j)即化为i行j列可以匹配。最后找出最少的覆盖点,由匈牙利定理:最少覆盖点=最大匹配边 。


    假设还是不懂能够參考这里点击打开


    AC代码例如以下:

    #include<iostream>
    #include<cstring>
    using namespace std;
    
    int v[505],s[505],map[505][505];
    int n,m;
    
    int xyl(int a)
    {
        int i;
        for(i=1;i<=n;i++)
        {
            if(!v[i]&&map[a][i])
            {
                v[i]=1;
                if(!s[i]||xyl(s[i]))
                {
                    s[i]=a;
                    return 1;
                }
            }
        }
        return 0;
    }
    
    int main()
    {
        int i,j;
    
        int a,b;
        while(cin>>n>>m)
        {
            memset(s,0,sizeof s);
            for(i=1;i<=m;i++)
            {
                cin>>a>>b;
                map[a][b]=1;
            }
            int sum=0;
            for(i=1;i<=n;i++)
            {
                memset(v,0,sizeof v);
                if(xyl(i))
                    sum++;
            }
            cout<<sum<<endl;
        }
        return 0;
    }
    










  • 相关阅读:
    C# 监测每个方法的执行次数和占用时间(测试1)
    C# 依赖注入那些事儿
    SQL Server GROUP BY 后 拼接 字符串
    C# 根据Excel生成树
    C# 反射赋值
    C# 集合转换为DataTable
    Oracle 未能加载文件或程序集Oracle.DataAccess
    MySQL 各种主流 SQLServer 迁移到 MySQL 工具对比
    平衡树
    数据结构优化dp
  • 原文地址:https://www.cnblogs.com/gavanwanggw/p/6851666.html
Copyright © 2020-2023  润新知