• POJ 1753 Flip Game(翻转棋盘+枚举+dfs)


    方法:一、枚举(此处所用)

              二、用二进制记录下标(尚未实现)

             三、类比于玩魔方游戏(思路来自黄超,尚未实现)

    原题链接:http://poj.org/problem?id=1753

    Flip Game
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 21024   Accepted: 9108

    Description

    Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
    1. Choose any one of the 16 pieces. 
    2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

    Consider the following position as an example: 

    bwbw 
    wwww 
    bbwb 
    bwwb 
    Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

    bwbw 
    bwww 
    wwwb 
    wwwb 
    The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

    Input

    The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

    Output

    Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

    Sample Input

    bwwb
    bbwb
    bwwb
    bwww

    Sample Output

    4
    

    Source

    题意:
             给你一个4*4棋盘,上面有且仅有白色(w)和黑色(b)两种颜色标记,并且,如果正面是白色,反面则是黑色,反之亦然。
    现在让你翻转棋盘,问最少翻转多少次,使得最后棋盘的颜色统一(即全为白色或者全为黑色)。
            如果不能翻转成功,则输出Impossible;否则,输出翻转成功的最小次数。
    注意:翻转方法,如果你翻转了一个棋盘的格子,那么此格子的上下左右格子就均被翻转。
    算法:枚举+dfs+回溯
    #include<stdio.h>
    #include<iostream>
    using namespace std;
    int chess[4][4];
    int c=33;
    void build()//将棋盘的颜色以标记化
    {
        char c;
        int i,j;
        for(i=0;i<4;i++)
        for(j=0;j<4;j++)
        {
            cin>>c;
            if(c=='w')
            chess[i][j]=0;
            else
            chess[i][j]=1;
        }
    }
    void turn(int x,int y)//翻转
    {
         if(x>=0&&x<=3&&y>=0&&y<=3)
         chess[x][y]=!chess[x][y];
    }
    void flip(int s)//一个棋子变化,周围四个都要变化
    {
        int i=s/4;//行
        int j=s%4;//列
        turn(i,j);
        turn(i+1,j);
        turn(i,j+1);
        turn(i-1,j);
        turn(i,j-1);
    }
    int complete()//判断棋盘是否变成同一的颜色
    {
        int i,j,s1=0;
        for(i=0;i<4;i++)
           for(j=0;j<4;j++)
              s1+=chess[i][j];
        if(s1%16)
          return 0;
        else
          return 1;
    }
    void dfs(int s,int b)//进行深搜.s代表当前的方格,b代表翻转的方格数
    {
         if(complete())//如果不是同一颜色
         {
             if(c>b)
               c=b;
            return;
         }
         if(s>=16)//如果遍历完
            return;
        dfs(s+1,b);
        flip(s);
        dfs(s+1,b+1);
        flip(s);
    }
    int main()
    {
        build();//将棋盘的颜色以标记化
        dfs(0,0);
        if(c==33)//由于翻转次数最多为4*4*2=32次
          printf("Impossible\n");
        else
          printf("%d\n",c);
        return 0;
    }



  • 相关阅读:
    EZchip花1.3亿美元买Tilera然后以8亿美元把自己与Tilera一起卖掉
    [OFC]Mellanox发布首个200Gb/s硅光子设备
    Mellanox 8亿美元收购EZchip
    EZchip将推全球首款100核64位ARM A-53芯片
    MyBatis映射文件5
    MyBatis映射文件4(参数获取#{}和${}/select标签详解[返回类型为list])
    MyBatis源码分析1 参数映射分析
    MyBatis映射文件3(参数处理Map)
    MyBatis映射文件2(不支持自增的数据库解决方案/参数处理[单参、多参、命名参数])
    MyBatis映射文件1(增删改、insert获取自增主键值)
  • 原文地址:https://www.cnblogs.com/freezhan/p/2776474.html
Copyright © 2020-2023  润新知