• KMP---POJ 3461 Oulipo


    Description

    The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

    Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

    Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

    So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A''B''C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

    Input

    The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

    • One line with the word W, a string over {'A''B''C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
    • One line with the text T, a string over {'A''B''C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

    Output

    For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

    Sample Input

    3
    BAPC
    BAPC
    AZA
    AZAZAZA
    VERDI
    AVERDXIVYERDIAN

    Sample Output

    1
    3
    0

    题目大意:找重复的子串


    #include<iostream>
    #include<string>
    #include<vector>
    using namespace std;
    int kmp_find(const string& target,const string& pattern)
    {
        const int target_length = target.size();
        const int pattern_length = pattern.size();
        int * overlay_value = new int[pattern_length];
        overlay_value[0] = -1;
        int index = 0;
    	//得到匹配值
        for(int i=1;i<pattern_length;++i)
        {
            index = overlay_value[i-1];
            while(index>=0 && pattern[index+1]!=pattern[i])
            {
                index  = overlay_value[index];
            }
            if(pattern[index+1]==pattern[i])
            {
                overlay_value[i] = index +1;
            }
            else
            {
                overlay_value[i] = -1;
            }
        }
        //match algorithm start
        int pattern_index = 0;//用来小串的移动
        int target_index = 0;//用来大串的移动
    	int sum=0;//统计一个几个
        while(target_index<target_length)
        {
    		if(target[target_index]==pattern[pattern_index])
            {//如果匹配就继续前移
                ++target_index;
                ++pattern_index;
            }
    		else{//如果不匹配
    			//这里注意下pattern_index=0的情况
    			//如果为0,然后上一步又不匹配,那么直接让++target_index;
    			if(pattern_index==0)
    			{
    				++target_index;
    			}
    		
    			//否则让pattern_index实现跳
    			else 
    			pattern_index = overlay_value[pattern_index-1]+1;
    		}
    		
    		if(pattern_index==pattern_length)
    			{
    				sum++;
    				pattern_index = overlay_value[pattern_index-1]+1;
    			}//注意这一步
    
        }
    	delete [] overlay_value;
    	return sum;
        
    }
    int main()
    {
    	int t;
    	cin>>t;
    	string source,pattern;
    	while(t--){
    
        cin>>pattern>>source;
        cout<<kmp_find(source,pattern)<<endl;
        }
    	return 0;
    }




    版权声明:本文为博主原创文章,未经博主允许不得转载。

    today lazy . tomorrow die .
  • 相关阅读:
    当前日志损坏解决一例
    Oracle 1204 RAC failover 测试 (一)
    Logical standby跳过个别SQL不Apply的测试
    Data guard 又出问题了
    CPIO无反应
    回答棉花糖先生关于我说的DB自动增加Index的问题
    SSD硬盘,先不要用在Server上
    ORA00304: requested INSTANCE_NUMBER is busy,终于解决
    .Net运行时的相互关系
    CSS布局探密04
  • 原文地址:https://www.cnblogs.com/france/p/4808736.html
Copyright © 2020-2023  润新知