• toj 2968 Find the Diagonal


    2968.   Find the Diagonal
    Time Limit: 1.0 Seconds   Memory Limit: 65536K
    Total Runs: 695   Accepted Runs: 223



    A square matrix contains equal number of rows and columns. If the order of the matrix is known it can be calculated as in the following format:
    Order: 3

    Order: 5

    and so on..

    Now look at the diagonals of the matrices. In the second matrix - the elements of a diagonal are marked with circles but this is not the only one in this matrix but there are some other minor diagonals like <6, 12, 18, 24> as well as <2, 8, 14, 20> and many others.

    Input

    Each input line consists of two values. The first value is the order of the matrix and the later is an arbitrary element of that matrix. The maximum element of the matrix will fit as a 32-bit integer.

    Output

    Each output line will display the diagonal elements of the matrix containing the given input element.

    Sample Input

    4 5
    5 11
    10 81
    

    Sample Output

    5 10 15
    11 17 23
    81 92
    

    Samina Azad (CSE-03)



    Source: CUET Easy Contest
    Submit   List    Runs   Forum   Statistics

    #include <iostream>
    using namespace std;
    int m , n , a1;

    int a(int i)
    {
      
    return a1 + (n + 1* (i - 1);
    }

    int main()
    {
      
    int i;
    start:  
    while (cin >> n >> m)
      {
        
    while (1)
        {
          
    if ((m - 1% n == 0 || m <= n)
          {
            a1 
    = m;
            
    break;
          }
          
    else
              m 
    -= n + 1;
        }
        cout 
    << a1 ;
      
    if (a1 % n == 0)
      {
        cout 
    << endl;
        
    goto start;
      }
        
    for (i = 2 ; ; ++ i)
        {
          
    int mm = a(i); 
          
    if (mm <= n * n)
          {
            cout 
    << " " << mm;
            
    if (mm % n == 0)
                
    break;
          }
          
    else
              
    break;
        }
        cout 
    << endl;
      }
      
    return 0;
    }
  • 相关阅读:
    python脚本2_输入2个数比较大小后从小到大升序打印
    python脚本1_给一个半径求圆的面积和周长
    配置双机互信
    如何在 CentOS7 中安装 Nodejs
    Git 服务器搭建
    docker安装脚本
    CentOS7下安装Docker-Compose
    Linux 文件锁
    6 系统数据文件和信息
    bash脚本编程之二 字符串测试及for循环
  • 原文地址:https://www.cnblogs.com/forever4444/p/1460363.html
Copyright © 2020-2023  润新知