• hdu 1078 (zoj 1107) FatMouse and Cheese


    FatMouse and Cheese

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 856    Accepted Submission(s): 262


    Problem Description
    FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

    FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

    Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
     

    Input
    There are several test cases. Each test case consists of

    a line containing two integers between 1 and 100: n and k
    n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
    The input ends with a pair of -1's.
     

    Output
    For each test case output in a line the single integer giving the number of blocks of cheese collected.
     

    Sample Input
    3 1
    1 2 5
    10 11 6
    12 12 7
    -1 -1
     

    Sample Output
    37
     

    Source
     

    Statistic | Submit | Back
    //1840787 2009-04-22 09:21:58 Wrong Answer  1107 C++ 10 184 Wpl 
    //1840859 2009-04-22 10:57:39 Accepted  1107 C++ 60 280 Wpl 
    #include <iostream>
    #define MAX 110
    using namespace std;
    int dp[MAX][MAX],map[MAX][MAX];
    int m,k;
    int a[4][2]={{1,0},{-1,0},{0,-1},{0,1}};
    void Init()
    {
        
    int i,j;
        
    for(i=0;i<m;i++)
            
    for(j=0;j<m;j++)
            {
                scanf(
    "%d",&map[i][j]);
                dp[i][j]
    =-1;
            }
    }
    bool Bound(int x,int y)
    {
        
    if(x>=0&&y>=0&&x<m&&y<m)
            
    return 1;
        
    else
            
    return 0;
    }
    int DFS(int x,int y)
    {
        
    int i,sx,sy,maxt,j,temp,mx,my;
        
    if(dp[x][y]!=-1)
            
    return dp[x][y];
        
    else
        {
            maxt
    =0;
            
    for(i=0;i<4;i++)
            {
                
    for(j=1;j<=k;j++)
                {
                    sx
    =x+a[i][0]*j;  //一开始因为这里写成k所以导致错误,以后一定要细心
                    sy=y+a[i][1]*j;
                    
    if(Bound(sx,sy)&&map[sx][sy]>map[x][y])
                    {
                        temp
    =DFS(sx,sy);
                        
    if(temp>maxt)
                            maxt
    =temp;
                    }
                }
            }
            dp[x][y]
    =maxt+map[x][y];
            
    return dp[x][y];
        }
    }
    int main()
    {
        
    int i,j;
        
    while(scanf("%d%d",&m,&k)!=EOF)
        {
            
    if(m==-1&&k==-1)
                
    break;
            Init();
            DFS(
    0,0);
            printf(
    "%d\n",dp[0][0]);
        }
        
    return 0;
    }

  • 相关阅读:
    MySql查看时间
    我的名人名言
    记录:今天架构让隔壁项目组使用MapDB,就好奇的百度了一下
    Hbase安装
    Hbase安装的坑: org.apache.hadoop.hbase.PleaseHoldException: Master is initializing(2)
    Hbase安装的坑:java.lang.ClassNotFoundException: org.apache.htrace.SamplerBuilder(1)
    Kafka安装
    linux下zookeeper安装
    启动kafka生产者报错: WARN [Producer clientId=console-producer] Connection to node -1 could not be established. Broker may not be available. (org.apache.kafka.clients.NetworkClient)
    org.postgresql.util.PSQLException: ������������: ��������� "runoobdba" ���������
  • 原文地址:https://www.cnblogs.com/forever4444/p/1456258.html
Copyright © 2020-2023  润新知