• zoj 3193 Accurately Say "CocaCola"! Again


    ZOJ Problem Set - 3193
    Accurately Say "CocaCola"! Again

    Time Limit: 1 Second      Memory Limit: 32768 KB

    In a party held by CocaCola company, several students stand in a circle and play a game.

    One of them is selected as the first, and should say the number 1. Then they continue to count number from 1 one by one (clockwise). The game is interesting in that, once someone counts a number which is a multiple of 7 (e.g. 7, 14, 28, ...) or contains the digit '7' (e.g. 7, 17, 27, ...), he shall say "CocaCola" instead of the number itself.

    For example, 4 students play this game. At some time, the first one says 25, then the second should say 26. The third should say "CocaCola" because 27 contains the digit '7'. The fourth one should say "CocaCola" too, because 28 is a multiple of 7. Then the first one says 29, and the game goes on. When someone makes a mistake, the game ends.

    During a game, you may hear a consecutive of p "CocaCola"s. So what is the minimum number that can make this situation happen?

    For example p = 2, that means there are a consecutive of 2 "CocaCola"s. This situation happens in 27-28 as stated above. 27 is then the minimum number to make this situation happen.

    Input

    Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 1000) which is the number of test cases. And it will be followed by T consecutive test cases.

    There is only one line for each case. The line contains only one integer p (1 <= p <= 12345678).

    Output

    Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the minimum possible number for the first of the p "CocaCola"s stands for.

    Sample Input

    2
    2
    3
    

    Sample Output

    27
    70
    

    Note: if you've read the problem Accurately Say "CocaCola"!, the only difference of this problem is just the two numbers in input section.


    Author: HANG, Hang
    Source: ZOJ Monthly, May 2009
    Submit    Status
    //1851884 2009-05-03 19:16:51 Accepted  3193 C++ 10 184 Wpl 
    #include <iostream>
    using namespace std;

    int main()
    {
        
        
    int p , t;
        
        cin 
    >> t;
        
    while (t --)
        {
            cin 
    >> p;
            
            
    if (p == 1)
                cout 
    << 7 << endl;
            
            
    if (p == 2)
                cout 
    << 27 << endl;
            
            
    if (p >= 3 && p <= 10)
                cout 
    << 70 << endl;
            
            
    if (p == 11)
                cout 
    << 270 << endl;
            
            
    if (p >= 12 && p <= 100)
                cout 
    << 700 << endl;
            
            
    if (p == 101)
                cout 
    << 2700 << endl;
            
            
    if (p >= 102 && p <= 1000)
                cout 
    << 7000 << endl;
            
            
    if (p == 1001 || p == 1002)
                cout 
    << 26999 << endl;
            
            
    if (p >= 1003 && p <= 10000)
                cout 
    << 70000 << endl;
            
            
    if (p == 10001)
                cout 
    << 270000 << endl;
            
            
    if (p >= 10002 && p <= 100000)
                cout 
    << 700000 << endl;
            
            
    if (p == 100001)
                cout 
    << 1699999<< endl;
            
            
    if (p >= 100002 && p <= 1000000)
                cout 
    << 7000000 << endl;
            
            
    if (p == 1000001)
                cout 
    << 27000000 << endl;
            
            
    if (p >= 1000002 && p <= 10000000)
                cout 
    << 70000000 << endl;
            
            
    if (p == 10000001)
                cout 
    << 270000000 << endl;
            
            
    if (p >= 10000002 )
                cout 
    << 700000000 << endl;
        }
        
    return 0;
    }
  • 相关阅读:
    H3BPM子表的复制
    vue规格新增一对多的例子
    vue自制switch滑块
    table垂直居中
    css清楚浮动的class
    网页之间的参数传递
    调用get_str_time(时间), 就能把毫秒的时间转换成格式化的 ,转化时间戳的方法
    css实现照片上传的加号框
    递归函数获得n个不重复的随机数
    随机生成n个不重复的数,范围是2-32,并让其在新页面打开
  • 原文地址:https://www.cnblogs.com/forever4444/p/1454657.html
Copyright © 2020-2023  润新知