• hdu3415(单调队列)


    Max Sum of Max-K-sub-sequence

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 10481    Accepted Submission(s): 3853


    Problem Description
    Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
    Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.
     
    Input
    The first line of the input contains an integer T(1<=T<=100) which means the number of test cases.
    Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).
     
    Output
    For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.
     
    Sample Input
    4 6 3 6 -1 2 -6 5 -5 6 4 6 -1 2 -6 5 -5 6 3 -1 2 -6 5 -5 6 6 6 -1 -1 -1 -1 -1 -1
     
    Sample Output
    7 1 3 7 1 3 7 6 2 -1 1 1
    用sum数组存前缀和,a【i.....j]=sum[j]-sum[i-1];max(a[1....j])=sum[j]-min(sum[i-1])    j-(i-1)<=k;
    用单调栈维护最小的sum[i-1]即可;
    #include<iostream>
    #include<algorithm>
    #include<cstring>
    using namespace std;
    int n,m;int a[100005],sum[200100],q[200100];
    int start,endi,total;int res;int ans;
    void get()
    {
    	int head=0,tail=0;
    	 ans=-100000000;
    	for(int i=1;i<total;i++)
    	{
    		while(head<tail&&sum[q[tail-1]]>=sum[i-1])tail--;
    		while(head<tail&&q[head]<i-m)head++;
    		q[tail++]=i-1;
    		if(sum[i]-sum[q[head]]>ans)
    		{
    			start=q[head];
    			endi=i;
    			ans=sum[endi]-sum[start];
    		}
    	}
    } 
    int main()
    {
    	int t;scanf("%d",&t);
    	while(t--)
    	{
    		cin>>n>>m;sum[0]=0;
    		for(int i=1;i<=n;i++)
    		{
    			cin>>a[i];
    			sum[i]=sum[i-1]+a[i];
    		}
    		for(int i=1;i<m;i++)
    		sum[n+i]=sum[n+i-1]+a[i];
    		total=n+m;
    		get();
    		start++;
    		if(start>n)start-=n;
    		if(endi>n)endi-=n;
    		 cout<<ans<<" "<<start<<" "<<endi<<endl;
    	}
    	return 0;
    }
    

      

  • 相关阅读:
    [mysql]修改 mysql 数据库端口
    [Angular]基础饼图之我如何将鼠标显示内容的数字 " 1" 去掉
    大三总结
    有符号8位整数的冒泡排序
    康托逆展开
    判断计算机是大端还是小端存储方式及分析
    C语言细节——献给入门者(三)
    C语言复杂声明
    病毒篇
    C语言细节——献给初学者(二)
  • 原文地址:https://www.cnblogs.com/flyljz/p/11385005.html
Copyright © 2020-2023  润新知