• 10300


    German farmers are given a premium depending on the conditions at their farmyard. Imagine the following simplified regulation: you know the size of each farmer's farmyard in square meters and the number of animals living at it. We won't make a difference between different animals, although this is far from reality. Moreover you have information about the degree the farmer uses environment-friendly equipment and practices, expressed in a single integer greater than zero. The amount of money a farmer receives can be calculated from these parameters as follows. First you need the space a single animal occupies at an average. This value (in square meters) is then multiplied by the parameter that stands for the farmer's environment-friendliness, resulting in the premium a farmer is paid per animal he owns. To compute the final premium of a farmer just multiply this premium per animal with the number of animals the farmer owns.

    Input

    The first line of input contains a single positive integer n (<20), the number of test cases. Each test case starts with a line containing a single integer f (0<f<20), the number of farmers in the test case. This line is followed by one line per farmer containing three positive integers each: the size of the farmyard in square meters, the number of animals he owns and the integer value that expresses the farmer’s environment-friendliness. Input is terminated by end of file. No integer in the input is greater than 100000 or less than 0.

    Output

    For each test case output one line containing a single integer that holds the summed burden for Germany's budget, which will always be a whole number. Do not output any blank lines.

    Sample Input

    3
    5
    1 1 1
    2 2 2
    3 3 3
    2 3 4
    8 9 2
    3
    9 1 8
    6 12 1
    8 1 1
    3
    10 30 40
    9 8 5
    100 1000 70

    Sample Output

    38

    86

    7445

    题意:总的保险费=一个动物占用面积×环境友好度×动物数量=农场面积×环境友好度;输入的三个值为:农场面积,动物数量,环境友好度。

    思路:其实将第一的乘第三个再加起来就可以。

    #include<stdio.h>
    int main()
    {
        int n,m,i,j,a,b,c,max;
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
                        scanf("%d",&m);
                        max=0;
                        for(j=0;j<m;j++)
                        {
                                        scanf("%d%d%d",&a,&b,&c);
                                        int d;
                                        d=a*c;
                                        max+=d;
                        }
                        printf("%d\n",max);
        }
        return 0;
    }
  • 相关阅读:
    Netstat
    Ant+jmeter+jenkins搭建测试的持续集成
    一个不会写代码的测试员
    JMeter监控内存及CPU ——plugin插件监控被测系统资源方法
    Ant+jmeter 实现自动化性能测试
    selenium+jenkins网页自动化测试的构建
    JMeter分布式测试
    jmeter压力测试的简单实例+badboy脚本录制
    js倒计时
    容器
  • 原文地址:https://www.cnblogs.com/fjutacm/p/2932713.html
Copyright © 2020-2023  润新知