• P1825 [USACO11OPEN]玉米田迷宫Corn Maze


    题目描述

    This past fall, Farmer John took the cows to visit a corn maze. But this wasn't just any corn maze: it featured several gravity-powered teleporter slides, which cause cows to teleport instantly from one point in the maze to another. The slides work in both directions: a cow can slide from the slide's start to the end instantly, or from the end to the start. If a cow steps on a space that hosts either end of a slide, she must use the slide.

    The outside of the corn maze is entirely corn except for a single exit.

    The maze can be represented by an N x M (2 <= N <= 300; 2 <= M <= 300) grid. Each grid element contains one of these items:

    * Corn (corn grid elements are impassable)

    * Grass (easy to pass through!)

    * A slide endpoint (which will transport a cow to the other endpoint)

    * The exit

    A cow can only move from one space to the next if they are adjacent and neither contains corn. Each grassy space has four potential neighbors to which a cow can travel. It takes 1 unit of time to move from a grassy space to an adjacent space; it takes 0 units of time to move from one slide endpoint to the other.

    Corn-filled spaces are denoted with an octothorpe (#). Grassy spaces are denoted with a period (.). Pairs of slide endpoints are denoted with the same uppercase letter (A-Z), and no two different slides have endpoints denoted with the same letter. The exit is denoted with the equals sign (=).

    Bessie got lost. She knows where she is on the grid, and marked her current grassy space with the 'at' symbol (@). What is the minimum time she needs to move to the exit space?

    去年秋天,奶牛们去参观了一个玉米迷宫,迷宫里有一些传送装置,可以将奶牛从一点到另一点进行瞬间转移。这些装置可以双向使用:一头奶牛可以从这个装置的起点立即到此装置的终点,同时也可以从终点出发,到达这个装置的起点。如果一头奶牛处在这个装置的起点或者终点,这头奶牛就必须使用这个装置。

    玉米迷宫的外部完全被玉米田包围,除了唯一的一个出口。

    这个迷宫可以表示为N×M的矩阵(2 ≤ N ≤ 300; 2 ≤ M ≤ 300),矩阵中的每个元素都由以下项目中的一项组成:

     玉米,这些格子是不可以通过的。

     草地,可以简单的通过。

     一个装置的结点,可以将一头奶牛传送到相对应的另一个结点。

     出口

    奶牛仅可以在相邻两个格子之间移动,要在这两个格子不是由玉米组成的前提下才可以移动。奶牛能在一格草地上可能存在的四个相邻的格子移动。从草地移动到相邻的一个格子需要花费一个单位的时间,从装置的一个结点到另一个结点需要花费0个单位时间。

    被填充为玉米的格子用“#”表示,草地用“.”表示,每一对装置的结点由相同的大写字母组成“A-Z”,且没有两个不同装置的结点用同一个字母表示,出口用“=”表示。

    Bessie在这个迷宫中迷路了,她知道她在矩阵中的位置,将Bessie所在的那一块草地用“@”表示。求出Bessie需要移动到出口处的最短时间。

    例如以下矩阵,N=5,M=6:

    =

    .W.

    .

    .@W

    唯一的一个装置的结点用大写字母W表示。

    最优方案为:先向右走到装置的结点,花费一个单位时间,再到装置的另一个结点上,花费0个单位时间,然后再向右走一个,再向上走一个,到达出口处,总共花费了3个单位时间。

    输入输出格式

    输入格式:

    第一行:两个用空格隔开的整数N和M;

    第2-N+1行:第i+1行描述了迷宫中的第i行的情况(共有M个字符,每个字符中间没有空格。)

    输出格式:

    一个整数,表示Bessie到达终点所需的最短时间。

    输入输出样例

    输入样例#1: 
    5 6
    ###=##
    #.W.##
    #.####
    #.@W##
    ######
    
    输出样例#1: 
    3
     
    Solution:
      本题较水。
      直接建图跑最短路就好了,将二维的坐标压成一维的点,对于相同字母的传送门,直接互相连向对方一步所能到达的点即可。
    代码:
    #include<bits/stdc++.h>
    #define il inline 
    #define ll long long
    #define For(i,a,b) for(int (i)=(a);(i)<=(b);(i)++)
    #define Bor(i,a,b) for(int (i)=(b);(i)>=(a);(i)--)
    using namespace std;
    const int N=1000005,dx[4]={1,-1,0,0},dy[4]={0,0,1,-1};
    int n,m,cnt,to[N],net[N],w[N],dis[N],h[N],S,T;
    bool vis[N],ct[30];
    char mp[302][302];
    queue<int>q;
    struct node{
        int a,b,c,d;
    }t[30];
    
    il void add(int u,int v,int c){to[++cnt]=v,net[cnt]=h[u],h[u]=cnt,w[cnt]=c;}
    
    il int id(int x,int y){return (x-1)*m+y;}
    
    il void init(){
        scanf("%d%d",&n,&m);
        For(i,1,n) scanf("%s",mp[i]+1);
        For(i,1,n) For(j,1,m)
            if(mp[i][j]!='#'){
                if(mp[i][j]=='=') T=id(i,j);
                if(mp[i][j]=='@') S=id(i,j);
                if(mp[i][j]>='A'&&mp[i][j]<='Z') 
                    (!ct[mp[i][j]-'A'])?(t[mp[i][j]-'A'].a=i,t[mp[i][j]-'A'].b=j):(t[mp[i][j]-'A'].c=i,t[mp[i][j]-'A'].d=j),ct[mp[i][j]-'A']=1;
                else{
                    int xx,yy;
                    For(k,0,3){
                        xx=dx[k]+i,yy=dy[k]+j;
                        if(xx<1||yy<1||xx>n||yy>m||mp[xx][yy]=='#')continue;
                        add(id(i,j),id(xx,yy),1);
                    }
                }
            }
        For(i,0,25) if(ct[i]){
            For(k,0,3){
                int xx=t[i].c+dx[k],yy=t[i].d+dy[k];
                if(xx>0&&yy>0&&xx<=n&&yy<=m&&mp[xx][yy]!='#')add(id(t[i].a,t[i].b),id(xx,yy),1);
                xx=t[i].a+dx[k],yy=t[i].b+dy[k];
                if(xx>0&&yy>0&&xx<=n&&yy<=m&&mp[xx][yy]!='#')add(id(t[i].c,t[i].d),id(xx,yy),1);
            }
        }
    }
    
    il void spfa(){
        memset(dis,0x3f,sizeof(dis));
        dis[S]=0,vis[S]=1,q.push(S);
        while(!q.empty()){
            int u=q.front();q.pop();
            for(int i=h[u];i;i=net[i])
                if(dis[to[i]]>dis[u]+w[i]){
                    dis[to[i]]=dis[u]+w[i];
                    if(!vis[to[i]])q.push(to[i]),vis[to[i]]=1;
                }
        }
        cout<<dis[T];
    }
    
    int main(){    
        init(),
        spfa();
        return 0;
    }
  • 相关阅读:
    网络攻击技术:SQL Injection(sql注入)
    人生若只如初见,何事秋风悲画扇
    TCPClient、TCPListener的用法
    C#中时间的Ticks属性
    string.Empty、" "、null 三者之间的区别
    telnet的使用解析
    public DataTable ExecuteQuery(string sql) 这段话具体意思
    C#中三层架构UI、BLL、DAL、Model详解(送给自学的初学者)
    数据库三层架构
    获取SQL Server数据库的表结构的做法
  • 原文地址:https://www.cnblogs.com/five20/p/9387892.html
Copyright © 2020-2023  润新知