• 第一次集训个人赛 T1(签到题)


    一、题目

    Description

    Wangpeng is good at drawing. Now he wants to say numbers like “521” to his girlfriend through the game draw something. 
    Wangpeng can’t write the digit directly. So he comes up a way that drawing several squares and the total area of squares is the number he wants to say. 
    Input all the square Wangpeng draws, what’s the number in the picture?
     

    Input

    There are multiple test cases. 
    For each case, the first line contains one integer N(1≤N≤100) indicating the number of squares. 
    Second line contains N integers ai(1≤ai≤100)represent the side length of each square. No squares will overlap. 
    Input ends with N = 0.
     

    Output

    For each case, output the total area in one line.
     

    Sample Input

    4
    1 2 3 4
    3
    3 3 3
    0
     

    Sample Output

    30
    27
    二、题目源代码
    #include<iostream>
    using namespace std;
    int main()
    {
        int i,n,sum,a;
        cin>>n;
        while(n)
        {
            sum=0;
            for(i=0;i<n;i++)
            {
                cin>>a;
                sum+=a*a;
            }
            cout<<sum<<endl;
            cin>>n;
        }
    
        return 0;
    }

    三、心得体会

    这是一道超级无敌大水题,本来是不用写解题报告的,可是我还是必须要写一下。因为在比赛的时候,我提交了两次这道题都没有AC,可是我觉得我做的挺对的,就继续做后面的了。到最后也没有AC.

    为什么?

    不认真读题!我没有注意到题目中说的 可以输入多组数据

    关于输入输出我还存在很大的不足,之后做题的过程中一定要注意!!

     
     
     
  • 相关阅读:
    20210309-2 阅读任务
    20210309-1 准备工作
    课程总结
    第十四周课程总结&实验报告(简单记事本的实现)
    十三周课程总结
    十二周课程总结
    第十一周课程总结
    C语言ll作业01
    C语言寒假大作战04
    C语言寒假大作战03
  • 原文地址:https://www.cnblogs.com/fightfor/p/3855129.html
Copyright © 2020-2023  润新知